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Chapter 1

Internet and e-mail

-

Internet

m |t's a large network of networks that covers
the whole world and enables millions of
computers from different organisations
and people to communicate globally.
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Description of Internet

Logical view of the Internet

g

Gomoster netesck

m The term Internet refers

to global interconnection
of computer networks for
the purpose of
communication and
resource sharing. Figure
left shows how
computes and computer
networks are
interconnected to form
the Internet. 5

Development of Internet (1969)

m In 1969, a research body in USA (ARPA)
Advance Research Project Agency set up
a computer network that connected for
universities and was given the name
ARPANET. ARAP’s goal was to allow
multiple users to send and receive
information at the same time.
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Development of Internet (1973-1981)

m By 1973, e-mail was the most common
service on the Internet. By 1981, many
people had seen the importance of
computer networking and the Internet.
ARAPnNet formed the backbone on which
many organisations started connecting to,
hence expanding it.

"
Development of Internet (1987-1994)

m By 1987, the Internet boasted of 10,000
host computers. As the importance of
Internet grew, businesses spent billions of
dollars to improve it in order to offer batter
services to their clients. By 1994, 3 million
computers were connected to Internet.
Today the Internet has grown and covered
the whole world.



g
Importance of Internet

m The importance of Internet can be seen
through its contribution to;

[1Research activities

ONews and information dissemination
CLeisure

OCommunication

[Business Transaction etc.

g
Internet Connectivity Requirements

m Telecommunication facilities

m Satellite transmission

= Modem

m Wireless telecommunication

m Internet Service Providers (ISP’s)
m Internet Software

10
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Telecommunication facilities

m Internet relies on telecommunication
facilities like telephone lines, telephone
exchange station and satellite
transmission in order to cover the whole
world. Therefore a computer is connected
to the external world through a telephone
line and has to dial a remote computer on
the net to establish connection for data

transfer.

g
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Satellite transmission
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m Intercontinental transfer of
data is achieved by having
satellite base stations
transmitting the data through
a wireless uplink channel to
the satellite. The satellite then
sends the data signal to the
base station on another
continent where it is picked
up and sent to telephone
exchanges for transfer to the
destination computer. Figure
left shows a logical local and
intercontinental connectivity.

12
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Modem

m It's a special digital to analog interface
card that changes data from digital to
analog so as to be transmitted on
telephone lines and on receiving end the
data is changed from analog to digital for
computer to understand.

13

'__
Wireless telecommunication

m With the dynamic growth in mobile
communication and computing, it is now
possible to access Internet using devices such
as mobile phones, PDAs and notebook PCs.
Heard about Wireless Fidelity to a hotspot?

Global system for mobiles (GMS) provides a
wireless connectivity to mobile devices users
known as General Packet Radio Service
(GPRS).

14
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Internet Service Providers (ISP’s)

m They are companies that offer Internet
Services to end users. They provide the
Internet services to end users at a fee.
Examples of ISP in Kenya include;

O Swiftkenya

1 Africaonline
OTodays online
COWananchi online
OInterconnect

15
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Internet Software

m Internet software help facilitate your
access to Internet. To achieve
communication between computers
special software called Protocol is
needed.

There are two types of protocols used
with Internet.

16



g
Types of protocols

m Transmission Control Protocol (TCP) — it
governs how data is transferred from one
computer to the next.

m Internet Protocol (IP) — it determines the
addressing system on the Internet.

17
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Internet Service 1

m E-mail — this is the exchange of electronic
letters, data and graphics on the Internet.

m Electronic Learning (E-learning) — this is
learning through interaction with special
programs on the computer.

m Internet fax — Internet provides you with
complete fax facilities from your computer.

18
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Internet Service 2

m Electronic Commerce (e-commerce) — it's
a commercial activity that takes place by
digital processes over a computer network,
usually the Internet between and among
entitles in the private sector, government
and members of public i.e. the buying and
selling of goods and services over the
Internet.

19

'__
Internet services 3

m Instant messaging — this is a more enhanced
messaging service that allows two or more
people to communicate directly. To get the
services, you must first register with an instant
messenger such as Yahoo! Messenger.

m Newsgroups — are organized groups of Internet
users who wish to share ideas and interests.
Once you join a newsgroups, you can
participate in discussion forums and debatesz.

0
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Internet Service 3

= World Wide Web (WWW) — in order to connect a
network to the Internet, the local area network needs
an Internet server. This server is given the name world
wide wed (www) and has all the information that
others on the Internet access. Individuals and
organisations establish sites where their web
documents can be placed for easy access by external
world. These sites are called websites and each has
a special address called Uniform Resource Locater
(URL) that is used to access them
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Accessing the Internet

m Applications that
enable a user to
access the Internet
are called Web
browsers e.g.
Netscape Navigator,
Internet Explorer,
Mozilla browser etc.

Mozilla browser

23

Login/Sign In

m To access a website, type the full address of
the website in the address bar then press
enter key. Some websites allow free access
to all their pages by all visitors. However
others require people to be members hence
a new visitor has to register (sign up). The
registration process gives the visitor a user
name, pass word that can be used to sign
in or log on the website for each visit.

24
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Surf/Browse

m Surfing /Browsing is the process of

accessing Internet resources like web

pages and website.

-

Parts of Internet Explorer window
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Uniform Resource Locator

m The Uniform Resource Locator (URL), simply
referred to as the web address, connects the
user to a particular website. The URL has two
basic parts.

O Protocol — standard used to connect to the resource
e.g. hypertext transfer protocol (http://) and file

transfer protocol (ftp://). For example, if you type
http://www.google.co.ke, Google home page is

displayed.
r1Domain name — name of the web server where the
resource is located. 27
g

Navigation toolbar

m The navigation toolbar (Figure below), consists
of buttons you can easily use to navigate the
web. These include; back, forward, refresh,
home, search and stop

Home Ias
Back Stop Favorite

Q= - 4 . e A LR
Qi 1 1 + Qe v

Next | oeach | Print
Refresh History 28
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Functions of each button on the navigation toolbar 1

m Back — returns the browser to the immediate
former web page.

m Next — moves the browser to the next web page in
case a person had clicked the back button.

m Stop — is used to stop loading the current web
page.

m Refresh —is used to reload a web page after
failuring the current attempt.

m Home — takes the user to the first page (the home
page) of the default website. 20

" NN
Functions of each button on the navigation toolbar 2

m Search — enables a person to search for
information on the website.

m Favourites — displays all links bookmarked to be
revisited later.

m History — displays the websites that were visited in
the recent past.

m Mail — is used to view and send e-mails.
m Print —is used to print web pages.

m Go —is used to load the website whose address is
in the address bar.

30
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Adding a website to favorites

m Bookmark those
web pages that you
are likely to revisit by
adding them to the

Bookmarking a web page
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N Lo
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|
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How to use favorites

m To bookmark a site;
On the Favorites menu, click “Add to Favorites’

2. Type or click “OK” to accept the name of the
new favorite.

3. To make the site available off-line, check
“Make available off-line”.

m To view or visit your favorite later;
1. Open the Windows Explorer.
2. Locate the favorites folder and open it.
3. Click the favorite you wish to view.

H

32
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Hyperlinks and Search Engines

m A Hyperlink is a text or picture on an
electronic document, especially web page
that causes web pages to open when the
link is clicked.

33

g
Search Engine

m |t's a program that
searches documents
i for specified keywords

S —— e
e e and returns a list of the

. documents where the

Tl keywords were found.
e The common search
R — engine includes;

i *  Google, Yahoo, MSN

etc.

34
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Downloading
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Printing a web page

Print command on the navigation toolbar

o

m After searching and

finding information on
the net, you may want
to save the information
locally on your
computer. The process
of transferring
information from a
remote computer to a
local storage is called
downloading.

35

Click “Print” button
on the “Navigation”
toolbar. (Print
dialog box is
displayed).

In the “General” tab,
select a printer
which you want to
use.

Set other options.
Click “Print” button.

36
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Electronic Mail (E-mail)

m Electronic mail refers to the sending and
receiving of electronic letters and
documents on the Internet.

37

'_
E-mail Software

m E-mail Software falls
under communication
By p— software that are
e ====——.  designed to help the
- user to read and send
I e —— . individual text
S -~ documents on the
= . - Internet so long as
z = the sender and
receiver have an e-
mail address.

38
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E-mail Facilities
= Mails
m File Attachment
= On-line meeting

m Telephone messages

m Contact Management

39

" S
Mails 1

m Checking Mail — in order to check mail the
user has to open the e-mail account by
providing the correct user name and
password. In e-mail account, click the
Inbox command to view a link list of all
received mails.

m Compose a mail — composing implies
writing. To compose a message, click the
compose command.

40
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Mails 2

m Send mail — to send mail, type the correct
e-mail address of the recipient in to; text
box, type four letter then click send
command.

m Forward mail — a received mail can be
forwarded to another recipient. After
reading click the Forward command and
then provide the address of the recipient.

" S
Checking for mails in Yahoo

m The use Yahoo mail, you first sign up for
an e-mail account. Yahoo assigns each
user a unique user name referred to as an
ID and a password.

42
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How to check an e-mail in Yahoo

1. Sign in using your
“ID” and “password”.

2. Click “Check mail”
button then “Inbox”

3. In the “Inbox” list
(figure left), click the
subject of the mail to
read.

4. Read the mail. Open
an attachment if any.

" A
How to check an e-mail in Outlook Express

1. Launch “Outlook

e e S TN A ]
[l W X Express” from the
~ Irbax = taskbar.
o0 |
o 2. On the Folders list,
. click “Inbox’
B
R Sucion
!-l-oou-u

3. Read the mail. Open
an attachment if any.

44
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E-mail compose window

A typical e-mail compose window has three basic
elements;

1. Header; the e-mail header is made up of the following
parts;

e Addresses of the recipients; the e-mail recipients can be more
than one.

Subject; presents the topic of the message.
e Attachment; files attached from other programs such as Word
processors and spreadsheets.
2. Message,; this is the content of the e-mail. It is typically
short and to the point. It may include text and graphics.
3. Signature; the signature provides additional
information about the sender such as full name,
address and telephone number. 45

'_
E-mail address format 1

= Just like the normal postal address, an e-mail address _
determines the destination of the e-mail sent. A typical e-mail
address would look like this;

takangaroo1031@gmail.com

1. takangarool031 is the user name and is usually coined by
the user during e-mail account registration.

2. @ is the symbol for “at” which separates the user name from
the rest of the address.

3. gmail.com is the name of the host computer in the network i.e.
the computer on which the e-mail account is hosted.

4. The period “.” is read as dot and is used to separate different

parts of the e-mail address.

5. com identifies the type of organisation offering a particular
service(s) and is called the domain, meaning it is a
commercial institution. 46

23
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Other commonly used domains

Domain |Type

.edu Educational institution

.gov Government institution

.org Non-profit making organization

.mil Military organization

.net An institution or organization providing
networking services

.ac An academic institution "

g

Other types of domain

m Sometimes a two letter extension is added after
the domain name to show the country where
the site is located.

e.g. tal9791031@yaho0.co.jp

the domain .jp stands for Japan. Other domain
names include .ke (Kenya), .uk (United
Kingdom), .ug (Uganda), .tz (Tanzania), .au
(Australia) etc. 48

24
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How to composing and sending an e-
mail

m To compose an e-mail

— in either in Yahoo mail
R AR S or Outlook Express;
— 1. Click the “Compose”
S W button.
om0 n 2. Type the recipient
2 ot | address or get it from the
-+ address book.
&2 3. Type in the subject of the

: : message as shown in
Sort bam > @ Tl ané Nemigroces Hotmail !
21 sofla : o Figure left.

4. Type in the message in
the message box.

5. Click the “Send” buttgp.

'_
File Attachment

m E-mail software enables a person to attach
other files like pictures, music, movies
Clips etc. To an e-mail for sharing with
others before sending. The source of
attached files can be from the hard disk or
other storage devices.

50
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How to attaching files into an e-mail

1. Click the “Attachment”
button on the toolbar.

2. In the Dialog box that
appears, select the
file(s) to attach.

3. Click “Attach” button to
attach the files.

NB; An attachment text box
Is automatically added
below the subject.

51

" S
On-line meeting

m |t's possible to hold on-line meeting with
people by sending mails to them e.g. On-
line interviews may involve a person
sending electronic mail composed of
interview questions to a recipient who can
read and answer back.

52
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Telephone messages

m Wireless Access Protocol (WAP) makes it
possible to send e-mail to a mobile
handset and a mobile message to e-mail
account.

53

gt
Contact Management

m Most mails programs allow the user to
develop an address book which holds
contact information like e-mail address of
different people.

54
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How to add a contact in Outlook express

)

N el 1. From “Tools” menu.
. Click “Address Book”.
3. Inthe “Address Book”

window, click the “New
it ' Contact” button.

4. Enter the contact details
e including the e-mail

B e address (figure left).
e — 5. Click the “Add” button to
s | ey —J— add the contact into the

® list, then close the
address book.

How to add a contact in Yahoo mail

1. From “CONTACT”
menu

2. Click the “Add New
Contact”

3. Enter other contact
details.

4. Click “SAVE” button.

56
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Accessing Information on Emerging Issues

Internet security 4 |nternet is a storehouse
of information, presented

sl in the form of text,
documents, pictures,
e sound and even video.
-~ . The Internet has a wide
e MY _.J. range |of information
s I concerning the issues.
:“‘-L Emerging issues refers
Sterier sotwsen to things like HIV/Aids,

HMEBN 00T

57

Review questions 1

Define the term Internet.
Give a brief account of how the Internet has evolved.

Explain three ways in which you can connect your
computer or web-enabled handheld device to the
Internet.

4. Using illustrations, discuss three types of transmission
media used to connect to the Internet.

5. Discuss how Wi-Fi and GPRS wireless connectivities
work.

Explain five uses of the Internet.

State three advantages and three disadvantages of the
Internet.

8. State three advantages of using wireless transmission
media to connect to the Internet. 58
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Answer of review questions 1-1

Global interconnection of computer networks.

2. Started as a research project in USA by ARPA. Today,
Internet is one of the most popular information service.

3. Using GSM, GPRS service, Wi-Fi or Satellite.

The student to draw or use conceptual diagrams on _
telecommunication lines, satellite or cellular (wireless) media.

5. GPRSis a GSM packet switching services while Wi-Fi
(wireless fidelity) is a long range radio connectivity standard
for mobile devices used to connect to Internet at hot spots.

6. Some uses of Internet include;
A) World wide web
B) Electronic mail
C) Instant messaging
D) E-commerce, e-learning and Newsgroup. 59

g
Answer of review questions 1-2

7. Advantages of Internet:
A) Efficient communication
B) Availability of information
C) Cost saving
D) Socialisation, etc.

Disadvantages of Internet:
A)  Setup cost may be prohibitive.
B) Security to data and information.
C) Inequality in society
8. Allow mobility
Ease of setup
Not quite expensive to setup
Do not take any physical space.

60
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Review guestions 2

1. State three measures you can take to have a targeted search
of Internet content.

2. Define the term “Internet blog” and list four types of blogs.

3. In what circumstances would you choose to view a document
as HTML instead of downloading it?

4. Explain how you would open a document in its original
application without downloading it.

Explain how you would send one e-mail to may recipients once.
Describe the three parts of an e-mail.

List three examples of e-mail client.

Differentiate between replying and forwarding and e-mail.
Explain how you would send an e-mail that includes photos,

© ® N o O

" BN
Answer of review questions 2

1. ldentify a search engine. 7. Email
Enter keywords. Yahoo! Mail
Use quotation marks to identify Endora

keywords.

2. Website that contains personal
information.

3. When not sure of its integrity or
source.

4. Right click then “Open target as...”.

Mailing group list.

Header (address, subject,
attachment)

Message

Signature

Microsoft Express.

. Replying means sending

back feedback to the sender
while forward is mailing a
received mail to a third party
recipient.

. Add file attachments the

photos should be in a jpeg.
or tif. format.
62
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Review questions 3

1. Outline the procedure for creating an e-
mail in Yahoo mail or Outlook express.

2. Explain how you add a contract into an
address book.

63
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Answer of review questions 3

1. Composing and 2. Outlook express:

sending e-mail. 1. From “Tools” menu, click
“Address Book”.

1. Click the compose 2. In the “Address Book” window,
button. click the “New Contact” button.

2. Type the recipient 3. Enter the contact details
address or get it from including the e-mail address.
the address book. 4. Click the “Add” button to add

. . the contact into the list, then

3. Typein the SUbJeCt of close the address book.
the mgssage. Yahoo mail:

4. _Type in the message 1. Click the e-mail address of the
in the message box. sender.

5. Click the Send button. 2. Click “Add” to contacts button.

3. Enter other contact detail§4

32
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Revision questions 1

© N o a A

Define the term Internet.
Explain the term web page format.

Explain the following Internet address
http://www.google.com in reference to the
structure of a URL.

Define the term Internet telephony.

What is the World Wide Web (www)?
What is a browser?

Explain the process of loading a website.
Explain four uses of e-mail software.

65

"
Answer of revision questions 1-1

It is a network of networks that covers nearly the
whole world and enables transfer of messages,
data and information across continents.

A hypertext page prepared to display content on
the web.

http — hypertext transfer protocol.

www — world wide web.

Google — name of computer with web content.
.com — commercial organisation.
Transmission of voice data over the Internet.

66
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Answer of revision questions 1-2

4. Avirtual space on the Internet that allows web
pages and sites to be accessed. Interlinked
pages formatted in virtual language.

Software that allows viewing of web content.

Start the browser software like Internet

Explorer. Type the URL address of the web

page you wish to access in the address bar

then press the Enter key to load the website.
7. Sending/receiving text and attachments.

Sending fax.

Keeping address book.

Mobile mail to mobile devices. o7

g
Revision gquestion 2

1. What s file download? Explain the procedure.
2. Explain the meaning of the word hyperlink.

3. Give three steps that you would follow to search for
information on the web.

4. What would you do if a website refused to load in the browser
on the first attempt?

5. Whatis a search engine?

6. Explain the meaning of the term Internet Service Provider
(ISP).

7. What three things apart from the computer are needed for one
to be connected to the Internet?

8. Whatis a protocol? Write th3e following in full: TCP/IP, HTML,
HTTP and ftp. o8
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Answer of revision questions 2-1

1. Downloading or saving files from remote hosts on the Internet
on to your computer.
O Procedure
i. Right click the link to the file.
i. Select the “Save” target as command.

ii. Select a folder and name for the file in the “Save as” dialog box then
click “Save”.

2. Atext or a picture that is a link to another webpage on the
Internet.

3. Check newsrooms for latest information on the topic then use a
search engine to look for links to the information required.

4. Click the refresh button on toolbar.

5. A search engine is a special program that collects and stores

links to information websites allowing user to search its
database for them. 69

"
Answer of revision questions 2-2

6. A company that offers Internet services to end users.

7. Modems, Internet software, Internet service provider,
telecommunication lines, TCP/IP protocols.

8. Modem — term stands for modulator demodulator. A
device that enables telecommunication use telephone
lines.

9. Are special communication rules that govern sending
and receiving of messages by computers on a network.

protocol (TCP).

Internet protocol (IP).

Hypertext markup language (HTML).

Hypertext transmission protocol (HTTP).

File transfer protocol (fip).

Oooooo

70
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Practical activity 1

1. If the computers in the laboratory are
connected to the Internet check on the
following.

a. The TCP/IP address of one of the computer

b. The DNS server address of your service
provider.

2. Using a laptop or mobile phone that is
configured with GPRS and a Bluetooth or
Wi-Fi connectivity, establish an Internet
connection.

4l

g
Practical activity 2

1. Launch Internet explorer and use it to visit one of the
academic sites such as a high school, colleges or universities.

Download a PDF file from the academic site you have chosen.

Create and send an e-mail to a friend inviting him/her for a
birthday party to be held on the coming Sunday. The mail
should include a picture of a cake.
4. Using a search engine, find information on the historical
development of the Internet. Copy and paste the material you
get in a five page Microsoft Word document that has the
following structure;
Title page.
Introduction.
Historical development of the Internet.
Future trends.
Conclusion.

Edit, format and save the document as History.doc 72
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Chapter 2

Pata security and controls

73

-

Data and information security

m Protection of data and information against
unauthorised access or modification.

m Denial of data and information to
unauthorised users.

m Provision of data and information to
authorised users.

74
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Data security core principles

m The three core
principles of data

Logical view of the internet )
security also referred

2D e to as information
G e SECUIity are
mjin} Tij]\ confidentiality,
wi T T 1] | integrity and
== N udl availability as shown

in CIA Triad diagram
figure left.

75

g
Data and Information Privacy

m Private data — refers to that or information that
belongs to an individual and must not be
accessed by or disclosed to any other person
unless with direct permission from the owner.

m Confidential data — this is data or information
held by a government or organisation about
people. The data must be protected against
unauthorised access or disclosure.

76
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Security threats and control measures

m Viruses

m Unauthorised access

m Computer errors and accidental access
m Theft

m Computer crimes

m Fraud

m Sabotage

m Alteration

77

'_
Viruses

m A computer virus is a destructive program
that attaches itself to other files and
installs itself without permission on the
computer when the files are opened for
use.

78
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Types of Computer Viruses

m Boot Sector — they destroy the booting information on
storage devices.

m File Virus — attach themselves to files.

m Hoax Virus — come as e-mail with an attractive subject
and launches itself when e-mail is opened.

m Tronjans — they perform undesirable activities in the
background without user knowledge.

m Worms — it sticks in the computer memory.

m Back doors — may be a Trojan or Worm that allows
hidden access to a computer system. 79

'_
Sources of viruses

m Contact with contaminated systems.
m Pirated software.

m Infected proprietary software.

m Freeware and shareware.

m Updates of software distributed via networks.

40
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Virus symptoms

m Unfamiliar graphics.
m Programs taking long to load.

m Unusual error messages occurring more
frequently.

m Less memory available than usual.
m Files/Programs disappearing mysteriously.
m Changes to disk volume IDs.

m Disk access seems excessive for simple
task.

81

g
Control measure against Virus

m |nstall the latest version of anti-virus
software on the computers.

m Avoid foreign diskettes in the computer
room.

m Avoid opening mail attachment before
scanning them for virus.

82
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Unauthorised access

m Physical access to computer system should be
restricted to ensure that no unauthorised person gets
access to the system. Unauthorised access may take
the following forms;

O Eavesdropping — this is tapping into communication
channels to get information.

O Surveillance (monitoring) — this involves where a person
may keep a profile of all computer activities done by another
person or person. The gathered information is used for other
illegal work.

O Industrial Espionage — spying on your competitor to get
information that you can use to counter or finish the
competitor 83

g

Control measure against unauthorised access

Encrypt the data and information during transmission.

Reinforce the weak access points like doors and
windows with metallic grills and burglar alarms.

Enforce network security measures.

Use file passwords.

Use of finger print identification.

Keep computer room closed when nobody is usingeit.
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Computer errors and accidental access

m Errors and accidental access to data and
information may be as a result of people
experimenting with features they are not
familiar with. Also people might make
mistake by printing sensitive reports and
unsuspecting give them to unauthorised
person.

85

"
Control Measures against
computer errors and accidents

m Give various file access privileges and
roles to the end users and technical staff
in the organisation.

m Set up a comprehensive error recovery
strategy in the organisation.
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Theft

m Theft plays a significant role in the loss or
damage of data. Theft of data happens
within an organisation with authorised
personnel stealing data for one reason or
another.

87

g
Control against Theft

m Employ guards to keep watch over data
and information centres and backup.

m Burglary proofs the computer room.

m Reinforce weak access points like the
windows, doors with metallic grills.

m Create backups in locations away from
main computing centre.
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Computer crimes

Trespass - this is the act of gaining access or entering
into a computer system without legal permission.

Cracking — this refers to the use of guess work over
and over again, by a person until he/she finally
discovers a weakness in the security policies or codes
of software.

Hacking — this refers to intentionally breaking of codes
and passwords to gain unauthorised entry to computer
system data and information files.

Tapping — in this crime, a person sends an intelligent
program on a host computer that sends him
Information from the computer.

Piracy — this refers to making illegal copies of
copyrighted software, information or data. e

g

To eliminate Piracy

m Make software cheap, enough to increase
affordability.

m Use licenses and certificates to identity
originals.

m Set installation password to deter illegal
installation of software.

90
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Fraud

m |t refers to the use of computer to cheat
other people with the intention of gaining
money or information.
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g
Sabotage

m This is illegal destruction of data and
information with the aim of crippling
service delivery or causing great loss to an
organisation.
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Alteration

m This is illegal changing of data and
information without permission with the
aim of gaining or misinforming the
authorised users.

93

g
Information system failure

m Some of the causes of computerized
information system failure include;
OHardware failure due improper use.

0Unstable power supply as a result of
brownout or blackout and vandalism.

O Network breakdown.
O Natural disaster.
OProgram failure.

94

47



" A
Control measures against hardware failure

Uninterruptable power supply m Protect computers
against brownout or
blackout which may
cause physical
damage or data loss
by using surge
protectors and UPS
such as the one
shown on figure left.
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Detection and protection against computer crimes 1

m Audit Trial — this refers to careful study of an
information system by experts in order to establish or
find out all the weakness in the system that could lead
to security threats and weak access points for crime-
ster.

m Firewalls — a firewall is a device or software system
that filters the data and information exchanged
between different networks by enforcing the host
network access control policy. Firewall monitor and
control access to and from protected networks.
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Detection and protection against computer crimes 2

m Log Files — they are special system files
that keep a record (log) of events on the
use of the computers and resources of the
information system. The information
system administrator can therefore easily
track who accessed the system, when and
what they did on the system.

97
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Detection and protection against computer crimes 3

m Data encryption — data transmitted over a network can
be protected from unauthorised access by mixing it up
into a form that only the sender and receiver can be
able to understand by reconstructing the original
message from the mix.

The process of encrypting and decrypting text

Black Cliphertext Black
—_—

panther . _ = panther

Plain text  Encryption key Deoryption key  Plain text o8
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Difficulty in detection and
prevention of computer crimes

m The crime might be complex.

m |t's not easy to find clear trail of evidence leading
to the guilty party e.g. No finger prints.

m There are no witness.

m Few people in management and law
enforcement know enough about computers to
prevent the crime. 99

"
Laws governing protection of information

m Data and information should be kept secure
against loss or exposure.

m Data and information should not be kept longer
than necessary.

m Data and information should be accurate and
update.

m Data should not be transferred to other
countries without the owner’s permission.

m Data and information should be collected, used
and kept for specified lawful purposes. 100
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Revision gquestions 1

Differentiate between private and confidential data.
Why is information a useful resource?
Explain any three threats to data and information.

Give two control measures you would take to avoid unauthorized
access to data and information.

Explain the meaning of industrial espionage.

6. Differentiate between hacking and cracking with reference to
computer crimes.

What reasons may lead to computer fraud?
Explain the term “information security”.

9. Why would data and information on an externally linked network not
be said to be secure even after burglar proofing a room?

10. How can piracy be prevented in regard to data and information?
11. Define a computer virus.

A w bR
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Answer of revision questions 1-1

1. Private data —belongs to individual and held by him/her.
Confidential data — held by Government or organisation.

2. Because of its importance in transactions, sharer ability and high
value attached to it.

3. Unauthorised exposure.
Unauthorised access.
Destruction by natural calamities.
Fraudsters and computer crimestars.
4. Keep data and information in well secured and restricted places.

Use passwords and access permission policies to control access to
the data.

Use firewall to enforce security policy.
Audit trials to identify threats to data and information.

5. The stealing of data and information for commercial gain and to
cripple competitors.

102
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Answer of revision questions 1-2

6. Hacking — breaking security codes.
Cracking — looking for weak access points in software
in order to get access to data and information.

7. For economic gain, Ego, etc.

8. Is the ensuring of safety of data and information
against threats.

9. Access can be made through the network.

10. Enforce copyright laws and other regulatory frame
works.

11.  Avirus is a destructive program that installs itself on
storage media causing improper functioning of the

computer system.
103
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Revision gquestions 2

1. Give four general rules that must be observed to keep
within the law when working with data and information.

2. Explain two types of computer viruses.
3. Whatis a program patch? Why are patches important?

4. Explain measures you would take to protect computers from
virus attacks.

5. What is data alteration? Explain its effect on data.

6. How can you control errors related to data and information
entry?

7. Data and information security has recently become very
important. Explain why?

8. Explain eavesdropping with reference to computer crimes.

9. Why use copyright laws for software data and information
necessary? 104
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Answer of revision questions 2-1

1.  Data should not be used for gain unlawfully.

The owner of data and information has a right to know what
data is held by the person/organisation having it.

Do not collect irrelevant and overly too much information for
the purpose.

Data should not be disclosed without the owner’s permission.
2. Trojans.

Boot sector viruses.

Backdoors.

3. A software update that when incorporated in the current
software makes it better. They enable better performance of
computer system.

4. Install anti-virus software. Also restrict foreign storage media
in the computer room. 105
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Answer of revision questions 2-2

5. Changing stored data without permission. This
changes the information inferences from data.

6. Define roles to various categories of users.

7. Because information is one of the most
valuable business resource for any
organisation or Government.

8. Listening to a transmission line to gain a copy
of the message being transmitted.

9. To deter illegal copying.
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Chapter 3
Word processor

Wjabini Boyo high ochool
gO/UI’YL e Wm/&

-

Introduction

m Word processer is an application software
that enable a user to create, save, edit,
format and print text documents.
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Advantages of word processer

m |[t's faster create documents with word
processor because of the availability of
facilities like formatting and editing features.

m  Word processor enables users to proof read
and spell check documents on the screen
before they are printed.

Allows multiple copy printing unlike typewriters.

Enables user to store documents for future
editing if need be.

m  Word processor has superior documents
formatting features.

109
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Basic features of word processor

m Allow the user to create, save, open and
format files.

m Have spell checker, thesaurus and grammar
checker.

Provide headers and footers, indexing.

Have ability to create and import tables, text
and graphics from other programs.

m  Word wrap — a feature that automatically
moves a word to a new line if it does not fit at
the end of the current line.
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Purpose of word processor

m Mostly word processor is used for typing
letters, memos, essays, books, reports,
minutes, circulars etc.

111

"
Examples of word processor programs

m Microsoft Word.
m Word perfect.

m Word star.

m Amipro.

m PC-Write

m Etc.

112
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Factors to consider when choosing a W.P.
m  Type of operating system.
m |t's user friendliness.
m |t's formatting and edition features.

NB; W.P. stands for Word Processor

113
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Starting Microsoft Word 2003

1. Click on the “Start”
menu.

2. Pointto
“Programs/All
Programs”

o 5 3. Point to “Microsoft

—— office 2003"

o P a. Click “Microsoft
Office Word 2003”

nnnnnnn

f i t

] EecONL L& -
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Parts of Microsoft Word 2003 window

115

Explain parts of MS-Word 2003 window 1

1. Title bar - it displays the title of currently
running application.

2. Menu bar — provides a drop down list of
commands that one can use to perform a task
e.g. File, Edit, View.

3. Tool bar — contains buttons and boxes that
allow you to perform tasks more quickly than
using menu bar.

4. Rulers — used to set tab stops, index
paragraphs, adjust column width and change
page margins.
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Explain parts of MS-Word 2003 window 2

Status bar — displays information about the
program currently running.

Work area — this is the area where you can
enter text or graphical objects.

Scroll bars — allows the user to “pan” the
windows up and that doesn't fit in the window.

Minimise button — reduces a window to
become a button on the task bars.

Maximise button/Restore — it stretches the
window to cover the entire screen or restore it
to it's original size respectively.

117

- O

MS-Word 2007 window
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Standard toolbar

Lol | A TR s tn-p s iRl ng o s sidll

m Standard toolbar contains commands used to
carry out common tasks such as launching a
new document window, opening a file, saving
spelling and grammar checking etc. To see
what the other commands are, just point to the
icon on the toolbar and a text tip will be
displayed showing the function of the icon.
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Steps of hiding and displaying the toolbars

T 1. On the “View” menu.
4 oo

L @ 2. Point to “Toolbars”

f
i
|
}
it
i

f

{

T

3. Click the type of
toolbar required to
select it.

|
L]
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Steps of hiding and displaying the Rulers

1. Click the “View”
menu.

2. Click “Ruler” (the
ruler is displayed or
hided on the screen).

121

Creating a document

m This is the process of typing text in a clean
page.

122
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Steps of “Creating a document”

1. On the “File” menu.

2. Click the “New”
(New document task
pane is displayed).

3. Click the “Blank
document”.

4. Click the “OK” button.

-

o At B AMIZE - a sl
EETRNWYLW) (X7 FECONVY T Ear 5 |
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NB; shortcut key
Ctrl + N

123

Creating a document based on a template

®m You may want create a professional or
elegant document such as resume, fax,
letters, memos or reports based on
existing Word templates.
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Steps of “Create a template document”

1. On the “File” menu.
2. Click the “New” (New document

. l task pane is displayed)

I o hee el | 3. In the “Templates” section, click
g 6 ) & J-a8 the “On My Computer”.
el e i g [ == (Template dialog box is

o 3_1 @g}i = displayed).

4. Select the tab that contain you

&g = 5 = want to use.

= T e __. 5. Select a type of template
= 2= document.

S ) T [ d1 o ll e

6.  Click the “OK” button. (Template
document is displayed)

7. Create this document.

125
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Saving a document

m This is the process of making a document
exist in your PC storage media, or on
secondary storage.

NB; PC stands for Personal Computer.
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Saving commands

m Save — this command saves the document
without changing the file name or the location.

m Save as - this command allows the user to save
the document for the first time, change the file
name or save on a different location.

m Saving with password — a password is a string of
characters used to prevent from unauthorised
users. A password Is case sensitive always note
the combinations of characters used.

127
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Steps of “Save” a document
1.  On the “File” menu.

2. Click the “Save”.

NB; shortcut key
Ctrl + S
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Steps of “Save as” a document

o "
- (e m—ry
N'-—M @

On the “File” menu.

Click the “Save as” (Save
as dialog box is displayed.)

Select location from save in.
Type file name in the box.

Click the “Save” button.

NB; shortcut key
F12

o gk wbh e

10.

129

On the “File” menu
Click the “Save as”
Select the location
Type the file name.
Click the “Tools

Click the “Security options”
(Security options dialog box is
displayed).

Type the password when
opening a document (you need
retype password for confirm).
Type the password to protect
against modification (you need
retype password for confirm).
Click the “OK” button.

Click the “Save” button.
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Closing the current document
1. On the “File” menu.
2. Click “Close”

NB; shortcut key
Ctrl + F4

131

Opening or retrieving an existing document

m This refers to opening a document which
has already been created and saved.

132
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Exiting from Word

m This refers to quitting the MS-Word
program completely

133

-
Steps of “Exit from Word”.

1. On the “File” menu.

2. Click the “Exit”.

= NB; shortcut key
Alt + F4
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Editing a document

m Editing — refers to making necessary
changes to an existing document.

135

-
Steps of “Open” the document 1

1. On the “File” menu.

2. Click the “Open” (Open
dialog box is displayed).

3. Select the location of
the file from “Look in”.
= §re 4. Click the name of the
iy {7 0 document you want to
<3 open.
:g o . [Q@ 5. Click the “Open” button.

NB; shortcut key
Ctrl+ O

136
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Steps of “Open” the document 2

= i = You can also open a file from a

§ recently used file list on the “File”

o menu. Word keeps a list of
T recently used files on the “File”
..... ; drop down menu.

(= 12 If recently documents isn’t displayed.

1. On the “Tool” menu.

2. Click the “Option” (Option dialog
box is displayed).
Click the “General” tab.

Select the “Recently used file list
check box.

= 137

Selecting with the keyboard

m To select one word, move the insertion pointer to
the beginning or end of the word then press
“Shift+Ctrl+Right” or left arrow.

m To select one line, press “Shift+Up” or
“Shift+Down” arrow key. Alternatively, move the
insertion point to the end or beginning of the line
then press “Shift+Home” or “End” keys
respectively.

m To select an entire page, press “Shift+Page
Down” or “Shift+Page Up”.

m To select the entire document, press “Ctrl+A” or
place the cursor at the beginning of the
document, then press “Shift+Ctrl+End”. 138
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Editing features of word processor 1

m  Typing mode

0 Insert mode — in this mode when text is
inserted between words or characters it
pushes the existing text away without
replacing it.

O Typeover mode — in this mode when text is
typed between words or characters the new
text automatically replaces the existing text
by deleting it. To switch between Typeover
and insert mode you press insert key.

139

"
Editing features of word processor 2

m  Find and replace — to search for a
particular word in document, the user
uses the find feature which automatically
locates the word. To replace a word, the
user the replace option.

m Proof reading — this refers to checking
whether the document has typographical
or grammar errors.
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How to switch “Typing mode”.

Insert mode

m Just type “Insert” key.

This key is one of the
‘ Navigation and
| Editing keys. And the
== s user can confirm
Type over mode current mode on the
status bar.

S o P <+ T
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Steps of “Find” function

1.  On the “Edit” menu.

2. Click the “Find” (Find
and Replace dialog box
Is displayed)

3. Type the word or phrase
to find in the “Find what”

. box.
L 4. Click the “Find Next”
[ v o wows b o ! o bUttOﬂ .

NB; shortcut key
Ctrl + F
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Steps of “Replace” function

e R

)

- O

Deleting text 1

1. On the “Edit” menu

2. Click the “Replace” (F&R
dialog box is displayed)

3. Type word or phrase to find
in the “Find what” box.

4. Type word or phrase to
replace in the “Replace
with” dialog box.

5. Click the “Replace” or
“‘Replace All” button.

NB; shortcut key
Ctrl+ H 143

m To delete a
character or a word
from the right to the
left:

1. Place the insertion
pointer on the
right of the word.

2. Press the
“Backspace” key.
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Deleting text 2

m Todelete a
character to the right
of the cursor
position:

1. Place the insertion
pointer on the left
of the word.

2. Press the “Delete”
key.

145
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Deleting text 3

m To delete a block of
T e text:

1. Highlight the text
to be deleted.

2. Pressthe
“‘Delete/Del” key.

146
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Proofreading tools 1

Spelling and grammar checker — this is an in-
built tool that helps the user to correct spelling
errors and incorrect grammar structures.

Thesaurus — it’s a tool that helps the user’s
finds words or phrases with similar meaning or
opposite meaning to the one selected.

Autocomplete — this is a feature displays a
word when the user types the first few
characters of the word.

Autocorrect — this feature automatically detects
wrongly spelt or capaitalised words and
replaces them.

147
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Proofreading tools 2

Highlighting/Selecting — it’s the process of
choosing particular areas in the text in order to
apply certain features.

Copy and move text and object — copying
means creating a duplicate of text or an object
in a document.

Undo and Redo — undo feature enables the
user to cancel the most recent editing action
while redo feature repeats the last action.
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Steps of “Spell and grammar” checker

Detionary lngasoe gkt (5.}
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Parts of “Spell and grammar” dialog box 1

Spelling and Grammar: English (U.S.)

Englsh (U.S.)

1.
2.

3.

On the “Format” menu.

Click the “Spell and
grammar” (if the
document has any
misspells or grammars,
S&G dialog box is
displayed).

Use this dialog box.

NB; shortcut key

F7 149
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Parts of “Spell and grammar” dialog box 2

1. Change — to correct only the highlighted

incorrect word.

2. Change All — to correct all the occurrences of

the misspelled word.

Ignore — to retain the highlighted and continue.

Ignore All — to retain all the occurrences of the
same word or phrase in the document from

another language.

5. Add dictionary — to add the word into the

custom dictionary.

-

151

Step of using “Thesaurus” 1

e SR NEEY B S S EUTRY |
» y— ——

Select a word or a
phrase you want to
research.

On the “Tools” menu
Point to “Language”

Click the “Thesaurus”
(Research task pane is
displayed).

Choose an alternative
word or phrase you
intend to use as
replacement for the

selected text. 152
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Steps of using “Thesaurus” 2

e r——

e e 1

-

5. To replace aword or a
phrase with an

antonym, select the
word or phrase
enclosed in brackets

6. Click the drop down list.
7. Click the “Insert”

NB; shortcut key
Shift + F7
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Steps of turn “Autocomplete” on/off

1. On the “Insert” menu

2. Point to “AutoText”

3. Click the “AutoText”

4. Select or clear the “Show

AutoComplete tip for
AutoText and dates”
check box.

5. Type in text in the “Enter

AutoText entries here”.

6. Click the “Add” button

7. Click the “OK” button
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Steps of turn “Autocorrect” on/off

1. On the “Tools” menu

2. Click the “AutoCorrect
Options”

3. Click the “Replace text
as you type” check box.

4. Type the commonly
misspelled word in the
“‘Replace” box

5. Type the correct spelling
for the word in the “With”
box.

6. Click the “OK” button

155

Steps of “Selecting” with mouse

1. To select a word, place the insertion pointer on
the word then, double click it.

2. To select the entire line, position the mouse
pointer on the left margin until it changes to an
arrow, then click once.

3. To select a paragraph, place the pointer at the
beginning or end of the paragraph. Notice that
the pointer changes to I-beam. Now drag the I-
beam over the text to be selected and release
the mouse button at the end of the text you
work on.
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Steps of “Copy and move” function

B e B S LYY

Paste

I"
o
e B
ﬂ 133
4
e
A W N

1
2
3.
4

Highlight the text or object.
On the “Edit” menu.
Click the “Copy”

Position the insertion pointer
where you want you copy
text.

On the “Edit” menu,

Click the “Paste.

NB; shortcut key of “Copy”

Ctrl+ C
shortcut key of “Paste”
Ctrl + V 157

Highlight the text or object.
On the “Edit” menu.
Click the “Cut”

Position the insertion pointer
where you want you copy
text.

On the “Edit” menu,

Click the “Paste.

NB; shortcut key of “Cut”

Ctrl + Z
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Steps of “Undo” and Redo”

1. On the “Edit” menu.

2. Click the “Undo” or
“Redo”

NB; shortcut key of
: “Undo”. Ctrl+Z
e e e e ' shortcut key of
“Redo”. Ctrl + Y
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Formatting document

m Formatting refers to applying various
styles or features to enhance the
documents appearance.

160
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Text formatting

m Refers to use of features such as bold,

colour, underline, changing fonts (type,
style) to improve text appearance.

161

g
Types of text formatting

Bolding — this feature makes the text look thick
and darker than the rest of the text in a
document.

[talic — this is to make the text slant forward.

Underline — this is placing of any line style
under text.

Superscript — this describes text that is slightly
higher than other text on a line.

Subscript — this describes text that is slightly
lower than other text on a line.

Change case - this refers to switching between
different cases provided by Microsoft Word.
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Steps of “Bold” function.

e T e e

(i) ‘ (D)~ |

- O

1. Highlight the text to be
bold.

2. On the “Format” menu.

3. Click the “Font” (Font
dialog box is displayed)

4. Click the “Bold” of the
“Font style”

5. Click the “OK” button

NB; shortcut key
Ctrl+B
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Steps of “ltalic” function
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1. Highlight the text to be
Italic.

On the “Format” menu.

3. Click the “Font” (Font

dialog box is displayed)

4. Click the “Italic” of the

“‘Font style”

5. Click the “OK” button

NB; shortcut key
Ctrl + |
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Steps of “Underline” function.
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5.

Highlight the text to be
draw the underline.

On the “Format” menu
Click the “Font” (Font
dialog box is displayed)
In the “All text” section,
select the underline type

from drop down list of
“‘Underline Style”

Click the “OK” button

NB; shortcut key for single

underline. Ctrl + U
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Steps of “Superscript” function
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Highlight the text to be
superscript.

On the “Format” menu.
Click the “Font” (Font
dialog box is displayed).
In the “Effects” section,

click the check box of
the “Superscript”

Click the “OK” button.

NB; shortcut key

Ctrl key plus + key
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Steps of “Subscript” function

1. Highlight the text to be
subscript.

2. On the “Format” menu.
Click the “Font” (Font

s 4 Y dialog box is displayed).
o — - 4. In the “Effects” section,
= = click the check box of
i | oA the “Subscript”

e P 5. Click the “OK” button.

NB; shortcut key

Ctrl and Shift keys plus
= key

167

Samples of text formatting

Njabini Boys high

Bold school

Underline (Single) Njabini Boys high school

Subscript Njabini Boys high ¢o0

168
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Change case

m When typing text, there are a number of cases
the user may intend to apply in order to create
contrast within the text. These are

O Sentence case — all the first characters in a sentence
are in uppercase (capitalised).

[0 Lowercase — all characters appear in lowercase.
O Uppercase — all characters appear in uppercase.

O Title case — all the first characters of each word in a
sentence appear in uppercase.

O Toggle case — it changes upper cases to lowercases
to and vice versa. 169

-

Steps of setting a “Change Case”

1. Highlight the text.

= 2. On the “Format”
dnge Case - X menu.
m ’ w-mh H “
omﬁ:‘m O Eubwidth 3. Click the “Change
8“’"““55 8&**“ case” (Change case
{Itle Case: Hragana : .
Ooae e Kb dialog box is
d:ll“l (oo ] displayed).
4. Select the case type

to be applied.

5. Click the “OK” buttqp,.
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Samples of “Change Case”

[Sentence case Njabini Boys high school

UPPER CASE Njabini Boys HIGH SCHOOL

tOGGLE cASE Njabini Boys hiIGH sCHOOL

171 |

" S
Paragraph formatting 1

m Text alignment — this refers to how text is lined
up on the page relative to the left, right or
centre of the page.

m Indent — indentation refers to moving the text
away from the margin.

m Line and character spacing — refers to the
vertical distance between lines of text while
character spacing on the other hand refers to
the space between the characters.

172
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Paragraph formatting 2

Tab — tabs are used to indent the first line of a
paragraph or create columnar data.

Bullets and Numbering — bullets and numbers
are used to mark steps in a procedure or items
in a list.

Drop caps —it's a large dropped initial capital
letter in a word or sentence.

Section breaks — break is used to identify

where a section, a columnar or a page ends
and the beginning of next.

173

g
Type of alignments

Lift alignment — text is lined up evenly
along left margin.

Right alignment — text is lined up evenly
along right margin.

Centre alignment — text are centered
unevenly between the left and right
margin.

Justification alignment — text is arranged
evenly along left and right margin.
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Steps of “Left alignments”

1.

Pragrass M

L .
T Al Bt T oot A et g b BV

e o navy B

Highlight the paragraph to
be left alignments.

On the “Format” menu.

Click the “Paragraph”
(Paragraph dialog box is
displayed)

In the “General” section,
select the “Left” from the
drop down list of
“Alignment”

Click the “OK” button

NB; shortcut key

-

Ctrl + L s

Steps of “Right alignments”

Pt b | L et Tur ety | b Tty 3.
Asyear we B P P
s 1
jre—
rue CrT—
T
s Ditaint | we *
D - S romi & 4
7 At e @ wge vt whur Suipe gty Syl .
e
e " 2 paern @
mMe - -
|7 S 2w o s Smavart v & vet

Highlight the paragraph to
be right alignments.

On the “Format” menu.

Click the “Paragraph”
(Paragraph dialog box is
displayed)

In the “General” section,
select the “Right” from the
drop down list of
“‘Alignment”

Click the “OK” button

NB; shortcut key

Ctrl + R 176
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Steps of “Centre alignment”

Pelets o lpamy e gt Dede ety | Ao Yooguty 3.
asgear we B PTOSTSSSR
e
@
=
et
e ataint | e L
e s o
7 A mmansde asn wre vt whor) diret ety Sbved 4
s sgoin |
My .- 2 — .
|7 St of e Smavart ord & vet

Highlight the paragraph to
be center alignment.

On the “Format” menu.
Click “Paragraph”
(Paragraph dialog box is
displayed)

In the “General” section,
select the “Centered” from
the drop down list of
“‘Alignment”

Click the “OK” button

NB; shortcut key

-

177

Ctrl + E

Steps of “Justification alignment”

N\ — & 3
OIS DR L el T Bt | A Tygepaty -
-yt O Sowe 3
- Q. .

. 2 . — 3 4
£l ibnte e 0t 1 et v et g S .
corn

Dlen Upwers &

-y o s - -
e
[ ) |

Highlight the paragraph to
be justification alignment.
On the “Format” menu.
Click “Paragraph”
(Paragraph dialog box is
displayed)

In the “General” section,
select the “Justified” from
the drop down list of
“Alignment”

Click the “OK” button

NB; shortcut key

Ctrl +J
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Steps of “Distributed alignment”

1.

Pty el ety e g ety | Sw Fmoaty 3

fagean b Bevien
Ly T en oo @- L3
e 3 > - - :
oe mered
. we 3

[ At 2 a3 1 G ¥t o Bt € 4

o
ay e~ 2 e -

77 ren 0 o whewr tmsmwre 91t & Mhved

I |

1 .

Highlight the paragraph to
be distributed alignment.
On the “Format” menu.
Click “Paragraph”
(Paragraph dialog box is
displayed)

In the “General” section,
select the “Distributed” from
the drop down list of
“‘Alignment”

Click the “OK” button
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Samples of text alignment

Left alignment

Njabini Boys high school

Distributed alignment

Njabini Boys high school

180 |
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Types of indents

m First line indent — this is where the first
line is indent while the other lines are left
along the left margin.

m Hinging indent — the whole paragraph is
indent except the first line.

m  Full indent — the whole paragraph is
indented.

181
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Steps of “Full indent”

Decrease indent

1. Highlight the
paragraph to be
indented or position
the cursor any
where in the
paragraph.

2. Click the “Increase”
or “Decrease Indent”
button of the
formatting toolbar.

182
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Steps of “First line Indent”

B it L R T L e e —— 2
ag— = M Botew

~ peoa

L : e

] st e s et fdn ==

-

e s vy 3 4
-~ s -

He g 0wt g vt

i [ =

Steps of “Hanging

1.
PR 0 R0 (e e B | G Trpg oy 2
e e i B
‘ et
roe
i
e 4.
- B
1 9004 90 SOcrE GV Tt
5.
T | & )
6.

Highlight the paragraph
to be indented.

On the “Format” menu
Click the “Paragraph”
(Paragraph dialog box is
displayed)

In the “Indentation”
section, select the “First
line” from the drop down
list of “Special’.

Select the how far from
margin from “By”

Click the “OK” button.

183

indent”

Highlight the paragraph
to be indented.

On the “Format” menu
Click the “Paragraph”
(Paragraph dialog box is
displayed)

In the “Indentation”
section select the
“Hanging” from the drop
down list of “Special’

Select the how far from
margin from “By”

Click the “OK” button.
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Samples of “Indent”

Name of indent Samples
First line indent ¢ '

Steps of change “Line Spacing”

1. Highlight the text to be

[ — line spacing.
e 2. On the “Format” menu
sy 3. Click the “Paragraph”

C B e w (Paragraph dialog box is
e displayed)
[t 4. In the “Spacing” section,
ne—Es | select the spacing
: required from the drop
| down list of “Line
) (T Spacing”

5. Click the “OK” button
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Examples of line spacing specifications

1. 1.5 line space.
2. Single line space.

3. Double line space.

187
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Formatting toolbar

Style t
Font Bullets  Outside Font &p::&wp

and
formatting Font style numbers  border colour subscript

style Font Paragraph Indent Hightlight Grow Language
size format and
shrink
font
m As mentioned earlier, the formatting toolbar lets
the user easily format text by clicking the

required format button as shown in above figure

188
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Steps of setting “Tabs”

1. On the “Format’ menu
2. Click the “Tabs” (Tabs

dialog box is displayed)
3. Enter a new value for tab
— : stop in the box of “Tab
T () stop position”
;'m Ot O3 4. Select the type of tab
-1,_@_, = from “Alignment”
O = 5. Select the type of leader.

6. Click the “Set” button
7. Click the “OK” button

189

-

Setting tabs using the ruler

1. Click on the “Tab”
button to choose the
required tab type.

it w 1_‘_ v Notice that the tab type
e keeps on changing as
N g you click the tab button.
J 2. Set the tab stop by

clicking where you want
it to be on the ruler.

3. Drag the tab stop.

190
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Types of “Tab”

Button |Name Purpose
Left tab Text is aligned to the left
\ Bar tab Inserts a vertical line at tab stop and
align text to the right of the line

Right tab Text is aligned to the right

191

"
Steps of “Bullets and Numbering”

1. Highlight the text

M 2. On the “Format” menu
e . Click the “Bullets and

= Numbering” Bullets and

i Numbering dialog box

. displayed)

i o b 4. Click the

) “Bulleted” ,"Numbered” or

e i Outline Numbered” tab.

5. Select the type of bullets or
numbering.

6. Click the “OK” button. 192
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Steps of “Drop cap” function

W2

L]

Dopped

Ws

lnu,:'wf

Opboes

Font:
Corbory

I

Lines to droge
Dutarce from tegr:

(6)

[—— =

3

“winle

0 e

-

Steps of setting “Section breaks”

Break

Ereak types

() Column break

) Text wrapping besak

Section braak types

O Next page

O Contirous

) Even page

O Qdd page

) [

33

Highlight the first
character in the
sentence.

On the “Format” menu

Click the “Drop Cap”
(Drop Cap dialog box is
displayed)

In the “Position” section,
select a “Dropped” or “In
Margin”

In the “Options” section,
select the font type from
drop down list of “Font”

Click the “OK” button

193

Position the text
cursor in the
document where the
break is to be
inserted.

On the “Insert” menu

Click the “Break”
(Break dialog box is
displayed)

Click the “OK” buttqg
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Page formatting 1

1. Page layout — this feature lets the user specify how text
will be placed on the page from the margins.

2. Page setup — the option lets the user specify the size of
the margins, paper size, paper source and layout.

Margins — these are the blank space around the

edges of the page.

Orientations — this refers to the positioning of the

page in relation to text.

a. Landscape orientation — in this text graphics are
printed with longest side of the page placed
horizontally

b. Portrait orientation — in this text and graphics are
printed with the longest side vertically upright.

195
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Page formatting 2

(V2

Vi.

Vii.

Page breaks — this identifies the end of one
page and the beginning of the text.

Columns — this refers to dividing of text into
a number of columns.

Headers and footers — headers refers to text
that is placed at the top of every page of a
document. Footers refers to text that is
placed at the bottom of every page.

Page numbering — refers to applying page
numbers on every page of the document.

196
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Steps of “Page layout”

1.

On the “File” menu.

Click the “Page
Setup” (Page Setup
dialog box is
displayed).

Click the “Layout” tab.
Set layout as desired.

Click the “OK” buttor?

Steps of setting “Margins”

On the “File” menu

Click the “Page
Setup”

Click the Margin tab.

In the “Margins”
section, enter the
values for the left,
right, top and bottom
margins in the
respective boxes.

Click the “OK” buttgp
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Steps of setting a “Orientation”

1.
2.

5.

-

Steps of setting a

1.
2.

5.

3.
4.

3.
4.

On the “File” menu

Click the “Page
setup” (Page Setup
dialog box is
displayed)

Click the Margin tab.

In the “Orientation”
section, select a
“Portrait” or
“Landscape”.

Click the “OK” buttgp

‘Paper Size”

On the “File” menu
Click the “Page
Setup” (Page Setup
dialog box is
displayed)

Click the “Paper” tab
In the Paper size”
section, select the
size from drop down
list.

Click the “OK” buttqp
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Steps of “Columns” function

1. Highlight the

_ paragraph.
=1 2 Onthe “Format’
Blafalwnfe=s] men:

o - 3. Click the “Columns.
‘L".‘IZ".., Ir (Columns dialog box
518 I is displayed)

4. Enter the number of
AR e 3 columns and set the

column width.
5. Click the “OK” buttop,

-

Steps of “Headers and Footers”

1. On the “View” menu

== I® 2. Click the “Headers and
Footers” (Headers and
Footers tool bar is
displayed)

3. Enter text or object in
the header area.

4. Switch to footer

- 5. Enter text or object in

| @ the footer area

6. Click the “Close” buiton.

101



gt
Steps of “Page numbering”

Coomee

[7] show number on test page

Inserting footnotes and endnotes

On the “Insert” menu

Click the “Page
Numbers” (Page
Numbers dialog box is
displayed)

Select the position from
drop down list of
“Position”

Select the alignment
from drop down list of
“‘Alignment”

Click the “OK” button

203

m Footnotes and endnotes are used in large
documents to explain, comment on, or
provide references for text in a document.
Footnotes appear at the bottom of the
page while endnotes appear at the end of
a section or the document.

204
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Steps of “Footnote and endnote”

} O g

¥ factaater

O frdhetes

Bottom of page 9

Tovnt
b formwt-
Cpbuns ek
St
hanters:

Nl changm
Ay Changes 1e:

Whede docursant -

(73, W |

-

Using styles list

1. On the “Insert” menu.
. Point to “Reference”

3. Click the “Footnote”
(Footnote and endnote
dialog box is displayed).

4. In the location section, click
“Footnotes” or “Endnotes”.

5.  Select the location of
footnote or endnote from
down arrow list.

6. Inthe format section, select
the types of “Number
format”, “Start at” or
“‘Numbering” .

7. Click the “Insert”. 208

1. Highlight the text you want
to use to create a style.

2. Apply various formats to the
text e.g. bold, italic,
underline etc.

3. Click the Styles box in the
formatting toolbar and type
a name for the style.

4. Press “Enter” key to apply
the style name.

NB; you can apply an existing
style. 206

103



-

Generating a table of contents and index

] el e 1. Turn to the page you

= want to insert the table
(= of contents.
=== 2. On the “Insert” menu.
Point to “Reference”

Click “Index and Tables”
(Index and Tables dialog
= e — box is displayed).

e 1 iz 5. Click the “Table of

‘ Contents” tab.

- ‘ 6. Set the table of contents.

7. Click “OK” button.

207

Creating tables

m A table is a feature in MS-Word made of
rows and columns that is used to organise
and enhance display and information.

208

104



- O

Steps of “Table” function

1. On the “Table” menu
Insert Table ri‘ 2 Point to “Insert”

Tabse sgo

inter of ko a_§ 3. Click the “Table”
e d O (Insert table dialog
Oredhmmdh o box is displayed)

) Btk to contents

:mlm“ ] 4. In the “Table size”
 { shyle: T _’W., -
section, select the

number of columns

() Preir s fo o s and rows from arrow

5. Click the “OK” buttop,

-

Steps of “create a table using the drawing tool”

Nppa—,
i= 1. On the “Table” menu.
| 2. Click “Draw table” (the
§i mouse pointer changes
| =— to a pencil symbol and
et Tables and Borders

s toolbar is displayed).

3. Drag the pointer to draw
the outline of the table.

4. Fillin the table with rows
and columns by
dragging the pointer as
you would draw using an
ordinary pencil.

210
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Uses/functions of tables

1. Used to organise and present
information.

2. Used to align numbers for calculation
purposes.

3. Can be used to create different forms
such as invoice, calendar etc.

211

" BN
Editing a table

1. Inserting rows/columns.
2. Deleting rows/columns.

3. Merging cells — refer to combining of
more than one cell in a table.

4. Splitting cells — refers to subdividing a
cell into more cells.

212
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Steps of insert “rows” in a table

[

W Gl ey
Bordors aed Shadog

Table Pyrgmtime

1.

- O

Steps of insert “Columns” in a table

2R

Imat ke
(ol *ILY,  Cohov te e Lok
Seheg LA ok b the i
- =G Pows Atrve
e ok 2l reos s
Solt Table :" o
Zh e o
et
Comgeet
W e
favia
_J T G
Sorders sed Shadey.

Soble Frsgmetes.

Place the cursor where
you want to insert a row.

On the “Table” menu.
Point to “Insert”.

Click the “Row above”
or “Row below”

213

Place the cursor
where you want to
insert a column.

On the “Table” menu.
Point to “Insert”.

Click the “Column to
the left” or “Column
to the right”.

214
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Steps of “delete rows, column or cells”

1. Select the rows,
- columns or cells to
' be deleted.

mm LG

e 2= 1@ 5, Onthe “Table” menu.

Vable Mot oot
e .
teadeg Save Bapeat

oy | 3. Point to “Delete”.

o ey
] Prvers e hadvy

[P 4. Click “Columns”,
“Rows” or “Cells”.

215
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Steps of “Merging cells” in a table

‘ 1. Select cells to be
e | merged.

2. On the “Table” menu.

- sl
Lm g 3. Click the “Marge
- cells.

216
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Steps of “Splitting cells” in a table

1. Select sells to be

split
Split Cells 3] . Onthe “Table’ menu
Number of golumns: $ 3. Click the “Split cells”
Niatber of pomist n =L (Split Cells dialog
‘ F box is displayed)
[#] Merge cells before spiit

4. Select number of
[ ok J|[ cancel | columns and rows
from arrow key

5. Click the “OK” button

217

-

Formatting a table

m MS-Word provides facilities that let user
format table border styles and shading.

218
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Steps of “Formatting table” function

1. On the “Table” menu

2. Click the “Table
AutoFormat” (Table
AutoFormat dialog box is
displayed)

3. Select the type of

e category from drop down

e list of “Category”

: - 4. Select the table style
from drop down list of
“Table style”

5. Click the “Apply” button

219
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Table conversions

m This feature allows the user to convert
table to the text and text to table.

220
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Steps of “Convert a table to text”

1. Select the entire table or
row and columns you

Convert Table To Text L.)—(J want to convert to text
Feparate text with 2. On the “Table” menu
O paragraph marks 3.  Point to “Convert”
®fabs] 4. Click the “Table to Text”
O Commas (Convert Table To Text
O Other: |- dialog box is displayed)

5. Enter or select the
character to be used as
a separator

6. Click the “OK” button

—

[Cam:elJ

@®|L—

221
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Steps of “Convert text to table”

1. Highlighting text you

Convert Text to Talile x| want to convert to table.
i Ty F—=a| 2. Onthe “Table” menu
M I 3 Point to “Convert”

Aot babsavior

Credamwan  fueo  H| 4. Click the “Text to table”

 Autofit to conterts

(o P (Convert Table To Text
Toble stk rone) sotoms.. | dialog box is displayed)
Separate text & :

¢ pwapaghs " Cogms 5. Enter or select the

£ . Lot 5 character to be used as

Gl ] o | a separator
6. Click the OK button..
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Performing arithmetic calculation in a table

m |t's possible to perform mathematics calculations such as
sum, products etc, if a table has numeric figures. To
calculate numerical values in a table, we use cell
references. A cell is a cross-section of row and column.
Columns are represented by letters A, B, C, .... while
rows are represented by 1, 2, 3 .... as shown in table

below figure.
Al |BL |C1 |[D1 |E1 |F1 |Gl [H1 |1 Ji
A2 |B2 |C2 |D2 |E2 |F2 |G2 [H2 |I2 J2
A3 |B3 |C3 |D3 |E3 |F3 |G3 |H3 |3 J3
A4 |B4 |C4 |D4 |E4 |F4 |G4 |H4 |14 J4
A5 |B5 |C5 |D5 |E5 |F5 |G5 |H5 |I5 B

-

Steps of use “Calculation” functions

x
Formmda
| REPTTYRY
fumdeer format
| =
Paste furction: Fate boobes
| =1 Iz
o
Sample of "Calculation” function
SUBJECT SCORE
Mathematics 60
English 90
Geography 79
Relizious education | 68
French 90
TOTAL 387

Click in the cell the
result to be displayed
Click the “Table” menu

Click the “Formula”
(Formula dialog box is
displayed)

Type a formula e.g.
=SUM(A1:E1) in the box
of “Formula”

Click the “OK” buttog,
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Sorting text

= In MS-Word you can sort a list of text,
numbers and dates in ascending or

descending order.

-

225

Steps of “Sorting text”

Cohaws ¢ v Ty rea - N2

Uy Paogachs Msber

Do By

v Tyoe

Usng Pararacin v

Thae Ry

My st hes
) Mander fawe () W Epter oy

) @

Highlight the text list or
table you want to sort.

On the “Table” menu.
Click the “Sort” (Sort Text
dialog box is displayed).
In the “Sort by” section,
select the type of data from
down arrow list i.e. “Text”,
“‘Number” or “Data”.
Select “Ascending” or
“‘Descending”.

Click the “OK” button. 228
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Malil merge documents

m Mail merge is the process of generating
personalised letters or documents by
combining a main document e.g. a letter
with an existing data source such as the
contact book.

227

-

Steps of setting a “Mail Merge” 1

1. Open or create a main
document such as form
letter. Main document
contains the information
you want to distribute.

2. On the “Tool” menu.

3. Point to “Letters and
Mailings,

4. Click the Mail Merge. (Mail
Merge task pane is
displayed). The pane
presents the user with a
step by step wizard that
guides takes you through
the process. 228
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Steps of setting a “Mail Merge” 2

Select document type

s (1

Select starting document

t-—:] 9.
|fZ;

Select document type. In this
case select the “Letters”

Click the “Next” arrow at the
bottom of the task pane.

Select starting document. In
this case select the “Use the
current document”.

8. Click the “Next” arrow.

Select recipients. In this
case select the (Type a new
list).

10. Click the “Next” arrow (New

Address List dialog box is
displayed).

229

Steps of setting a “Mail merge” 3

New Address List dialog box

11.
v 12.
11
13.
Customize Address List dialog box
[ )
M“:-:- =
ST = 14.
ey —
i ] 15.

Click the “Customize”

button (Customize Address
List dialog box is displayed)
Customize address list (add,
remove or rename fields).
After you finish to
customize, click the “OK”
button (Customize Address
List dialog box is closed).

Click the “Close” button
(Save Address List dialog
box is displayed).

Save the data source. ,,,
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Steps of setting a “Mail merge” 4

Mail merge toolbar 16. After you save the data
source, “Mail Merge
Recipients” dialog box is
displayed. Click the “OK”
- button of this dialog box.
17. A Mail Merge toolbar is

added onto the data source.
Move the mouse pointer to
, get the tool tip for each
Write your letter button as shown left above

r 7 figure.

(e 18. Edit data source to type
e recipients data.
=T 19. Click the “Next” arrow.

[Eee— 20. Click the “More items”
o (Insert Merge Field dialgg
box is displayed).

Steps of setting a “Mail Merge” 5

Insert Merge Field dialog box
e | 21. Insert each field as
= desired.
e 22. After you finish to insert
SR g each field, click the
== “Close” button.
o 23. Click the “Next” arrow
T two times.
e You are now ready to
merge. 232
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Preview merged documents

Print button on the merge toolbar

VT WIS W PR )
—

A2 MBI X e an)

[
e
..).;;-,'z'.i.gzll

VY
ERCY Ry Xy
. e WYY
D L) . - ] TA”

Merge to Printer dialog box

Merge to Printer @
Print records
@l
) Current record
O Erom: To:
C o (o ]

"

m Before you print click
the “Preview” button in
order to be sure that
everything is in the
right place. To send a
merged document to a
printer, click the “Print”
button on the mail
merge toolbar. A
dialog box similar left
figure is displayed.

233

Send merged documents via e-mail

Merge button on the merge toolbar

R

m.u_rk_,;_.___njm-;!._.z_gzl
o pse AL RS H;l-r' RS )
S LA B ol

Y 1 e

Merge to E-mail dialog box

Pemna cptors

w Crand_Ackbum -

Pttt tne | Vodiry Order

Pl Torwat | Antyctoent -
R 1

on

£ Quvgrd record

O proms Jet

= corent ]

m Click the “Merge” button on
the Mail Merge toolbar to
see dialog box of left figure.
Select “E-mail” or “Fax” in
the merge to box. Click the
“Setup” button to specify
the e-mail addresses or
faxing number then click
the merge button. The
internet connection wizard
starts and if your computer
Is properly configured, the
mail merged document will
be sent.
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Files in mail merge

1.

The primary file (Main document) — this
file contains data that will appear in all
documents.

Data source (secondary file) — this file
contains variable information e.g. names,
address, telephone etc.

Merged file — once you finish inserting
merge fields from the data source in the
main document. You can merge.

235
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Inserting graphics

Inserting graphics — refers top non-text
Image generated by a computer.
Graphics can be photographs, drawings,
pictures, charts and graphs. In MS-Word
graphical objects are inserted from
(source). Clip gallery, scanner, drawing
tools, charts, from another file.
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Steps of “Insert a graphics from clip art gallery”

1.

Position the insertion pointer
where you want your object
to be inserted.

On the “Insert” menu

3. Point to “Picture”

Click the “Clip Art” (Clip Art
task pane is displayed)
Type the category name in
the “Search for” box

Click the “Go” button (Some
graphics are displayed)
Select a graphics and click
the “Insert” of drop down
menu. 237

Steps of “Insert an image from a scanner”

1.

Example of dialog box of scanner introductions

Insert Picture from Scanner or Camera

N

Position the insertion pointer
where you want your picture
to appear

On the “Insert” menu

3. Point to “Picture”
4. Click the “From Scanner or

Camera”

. To scan, follows the

instructions that come with
your scanner

When the image appears on
the screen you can edit
format it as required, the
same way you would with a
clipart. 238
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Steps of “Inserting a picture from another file.

o ——
il== : 1. Position the insertion
= pointer where you want
B=— your picture placed.

. On “Insert” menu.
3. Point to “Picture”.
4. Click “From File” (Insert

Picture dialog box is

: displayed).

e i 5. Locate the file that contain
L, . = = the image you want to

R B e insert e.g. My Picture.

-— 6. Select the object you want
:‘T | B to insert.

7. Click the “Insert” button.
239

Steps of “Insert graphics from Drawing Tools”

1. On the “View” menu.
2. Point to “Toolbars”.

3. Click the “Drawing”
(Drawing toolbar is
displayed).

4. Draw a line, a circle,
an arrow or a
rectangle using this
toolbar

240
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Steps of “Insert graphics from Autoshapes”

=y
OOADL!
DOC)(:}M
8600
o8~
L - N |
(1) P PR = = A B RO &) [T
[ sec1 o omae i ) 3 wee|

S e A

- O

d ow

Click the “Autoshapes”
button on the drawing
toolbar (drop down menu
is displayed).

Point to category
required.

Select a type of object.

Place the pointer where
you want to draw that
shape and drag to the
required size.

241

Steps of “Insert a chart”

Position the insertion

pointer where you want

your object to be
inserted.

On the “Insert” menu
Point to “Picture”
Click the “Chart”

(Datasheet is displayed)

Edit the “Datasheet”
Click the “X” button za2
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To format or edit a picture

More

and
Color Less Compress Format Reset
mode  Brghtness FWp Pictures Picure  Picture

FIE TSP T

Insert More Crop Line Style Text Sel
Picture and Wrapping  Transparent
Less Picture
Contrast

m MS-Word provides the user with a picture editing toolbar that
lets you adjust the brightness, contrast, change it to black
and white or grayscale and crop the image. Cropping refers
to hiding the unwanted details so that they do not come out
when printing. To display toolbar, click on View menu, point
to toolbars then select Picture. The picture toolbar has
buttons that enable a person to format a picture as shown in
above figure. 243

"
Steps of “resize or move a drawing”

1. Click anywhere
inside it, the place
! : holder appear.

2. To move it, hold
down the mouse
button and drag.

N 3. Toresize it, place
~® the pointer at one of
the place holders
and drag.

244
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Steps of “fill the object with colour”

Double click the
object (Format
AutoShape dialog
box is displayed).
Select the “Colors
and Lines” tab.

In the Fill section,
select the colour you
want to fill from drop
down list of Color.

Click the “OK” button.

245

Steps of “fill effects”

-

-
LA AL L)

ey

Double click the object
(Format AutoShape dialog
box is displayed).

Select the “Colors and
Lines” tab.

In the Fill section, click the
“Fill Effect” from drop down
list of Color (Fill Effect
dialog box is displayed).
Select the appropriate fill
effect.

Click “OK” button of Fill
Effect dialog box.

Click “OK” button of Format
AutoShape dialog box 246
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Inserting symbol

m A symbol is a special character that is not
included on the standard keyboard. For
example, @ and u are symbols that are not
available on the standard keyboard.

247

"

Steps of insert a “Symbol”

1. Move the text cursor to
the position where the
new symbol will be

Yot ™

Ttoh | Sgeces Chaiwn

W [ Sermeaem Dot v (0B, e

T R T T T 8 inserted.
ApIx|=[olnlp[E [Ty 'l»_@l;‘x ) )
alelqjejolalplyioleiClnio]sfuih 2. On the “Insert” menu.
ll.".; ".v".‘.‘, 2 n‘(. v 'I_'.j’."v' wl ‘.«.‘-I- . “ N

olo[E[D]FlelsTT[T] T [m[n[K]F, 3. Click the “Symbol
Talajol¢|€|e]¥[o]e[m]=]<[=]-] (Symbol dialog box is
o v . Db [ =y = d|sp|ayed)

4. Select a symbol you
want to insert from list.

5. Click the “Insert” button.
6. Click the “Close” buttogrs
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Printing

m The choice of printer depends on the
guality of hardcopy desired. Before
printing it's important that you preview

your document. To confirm that no details

are outside the printable area. To ensure
that the document layout is okay.

"

Steps of “Print” function

On the “File” menu
Click the “Print” (Print

NB; shortcut key

249

dialog box is displayed)
Select printer, page
range and number of

Click the “OK” button

250
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Review guestions 1

1.  What is a word processor?
State the purpose of word processor.

Name four functions performed by a word
processor.

What is a document draft?

5. State four advantages and two disadvantages
of using a word processor over the typewriter.

What is document formatting?

7. Explain the difference between type over and
insert mode in word processing.

8. Define the term word wrap.

251

g
Answer of review questions 1-1

1. A computer program that enables a person to create, save,
retrieve, edit, format and print text based documents.

Writing letters, projects, reports, essays and books etc.
Creating, printing, saving, editing, formatting documents.
One that is the initial copy for proofreading.
Advantages;
A) A document can be stored for further use.
B) Typing is easier and efficient.
C) Word processors have superior document formatting features.
D) Itis possible to print multiple copies at once.
Disadvantages;
A)  Computers are more expensive.

B) Computers use electricity hence not appropriate where there is
no electric power.

o M w DN
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Answer of review questions 1-2

6.

8.

Making a document attractive by bolding,
italicising, bordering, colouring, etc.

Type over — deletes current text at cursor
position and inserts new text.

Insert mode — pushes old text away as
new text is inserted at cursor position.

Automatically moving a word to the
beginning of a new line if it cannot fit at
the end of the previous line without
pressing outer key.

253
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Review questions 2

1.

2.

State two examples of word processing
programs.

What is a toolbar?

Explain how you can protect a document from
unauthorised opening or altering.

What is meant by the terms creating and
editing a document?

How can you save a document to a different
word processor format?

Define the tem scrolling.
Explain the importance of the status bar.

254
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Answer of review questions 2

Microsoft Word, Wordstar, Lotus Wordpro,
Wordperfect.

A group of shortcut command icons arranged on a
single graphical structure.

Use passwords to prevent opening or editing.

Creating — typing text in a new document screen.
Editing — making changes to an already existing
document.

Click file then Save as command. In the save as dialog
box, select a format type in the File of type box. Click
Save button to save.

Moving of on screen pages up, down, left and right.
Help the user to interact with the application because it

displays the processing status of the application. »ss

" BN
Review guestions 3-1

P w PR

Explain the meaning of the term blocking text?
What is the difference between copying and moving text?
When is the find and replace command used?

What is a wildcard? How can it be used to search for a
word that starts with the letter “O” in a document.

What is the difference between just searching for a
particular word in a document and searching for a word
that is whole?

Explain the importance of proofreading a document.
Give two methods of proofreading a prepared document.

Give the two types of dictionaries that are used by a spell
checker program. Which one is likely to have non-English
words and why?
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Review questions 3-2

9.  Name any five parts of the Microsoft Word application
window.

10. Give any five document formatting.
11. Give any five document formatting feature.
12. What is a thesaurus?

13.  Distinguish between the autocomplete and the
autocorrect feature in word processing.

14. Hassan has a problem when typing; every time he
wishes to type the word Good, he mistakenly types
God. What can he do to continue typing without
worrying about having to go back to correct the same
word over and over again?

15. Explain the use of undo and redo commands.
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g
Answer of review questions 3-1

1. Selecting several lines of text in order to work with them as a
whole.

2. Copying — making a duplicate copy of text. Moving — relocating
text from one place in a document to another.

3. To search for words that you want substituted by others.

A special character e.g. * or? Used to represent a set of words
that have some similar characteristics. Type 0 followed by asterisk
(*).

5. Searching for a word will find the word even when it is part of
other words e.g. searching for spell will also find Spelling and
Spellchecker. However, if you search for a whole word, only the
whole independent text will be found, e.g. only Spell and no other
will be found.

Eliminate mistakes to improve a document readability.
Spelling and grammar checker, Thesaurus, and
Autocomplete/Autotext/autocorrect.
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Answer of review questions 3-2

10.
11.

12.

13.

14.

15.

Standard dictionary and custom dictionary.
custom dictionary — words can be added.

Title bar, Menu bar, Editing screen, Rulers, Toolbars and status
bar.

Enhancing a document’s appearance by bolding, italicising, etc.
Bolding, Font colouring, Text alignment, Font type, Setting tabs,
Underlining, Italicising and Font size.

Thesaurus provides synonyms or words that have same meaning
as the one selected.

Autocomplete — helps a person to type quickly by completing a
word that has already started to be typed by the user
automatically. Autocorrect — automatically replaces mistyped
words with the correct ones as set by the use.

Set the autocorrect feature to automatically detect and replace the

word God with Good.

Undo — reverses the latest action. Redo — does the undone action.
259

g
Review questions 4

Give at least four examples of fonts available in
Microsoft Word.

Outline the procedure for inserting:
Page numbers;
A) Footnotes and endnotes;

B) Headers and footers;

Cc) What is a tab? Why are tab stops important in a
document?

Explain the importance of drop cap in a document.

What is line spacing? Give any two line spacing
specifications.

Give and explain four text alignment features.
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Answer of review questions 4

Times New Roman, Arial, Bookman Old Style, Comic Sans MS,
etc.

A). Click Insert menu, Page numbers.
B). Click Insert menu, Reference.
C). Click View menu, Header and Footer.

A tab spacing is a short distance moved by the text cursor
when the tab key on the keyboard is pressed. It is used to align
text on the page.

Drop cap emphasises a particular starting word in a paragraph.

5. The distance between two text lines in a document. Examples

include single space, double space, etc.
Left alignment, Center alignment, Right alignment and Justified.
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Review questions 5

Differentiate between drawing and inserting a table in a document.
Define the term cell in reference to tables.

Give a reason why in may be necessary to merge cells in a table.
Define the term sorting.

Explain how you can convert some typed text into a table using
Microsoft Word.

What would happen to the cursor in a table when the following actions.
A) Pressing the tab key.

B) Pressing the shift+tab key.

C) Pressing the enter key.

Define the term function as used in table calculations.

Define each of the following:

A) A form letter.

B) A data source.

C) Mail merge.

List four ways of merging a document with its data source 262
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Answer of review questions 5

1. Drawing — use the pen tool to draw the table. Inserting table — use the Table
menu-Insert-Table command.

Cell — section between a row and a column.

To create larger cells in a table without increasing the height or width of
existing cells.

Arranging text in ascending or descending order.

Highlight the text then click Table-Convert text to table.

A). Moves text cursor one column to the right in the same row.

B). Moves text cursor one column to the left in the same row.

C). Increases cell height.

Mathematical formula that accomplish calculations in a table.

A). Common letter (main document) that is to be personalised.

B). A file of data records of the people that will receive the form letter.
C). Combining the data source with the form letter or main document.

9. Merge to fax, Merge to printer, Merge to e-mail and Merge to new document.
263

g
Revision questions

Define the term graphic and give one example.
Explain how to achieve the following
A) To move a graphic from one place on the page to another.
B) To change the brightness of a graphic.
3. List three sources of graphics that can be used in Microsoft Word.
. What is an autoshape?
5. How can you do the following
A) Change the thickness of an autoshape outline;
B) Fill an autoshape with colour;
C) Enter text in an autoshape.
What is the difference between object linking and embedding?

Describe how you would increase the size of a clip art that is
embedded in a document.

Give any three sources of images or objects in a word processor.

9. Explain the concept of importing objects into a word processor.
264
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Answer of revision guestions

. A graphic is a non-text object like a picture, drawing, etc. e.g. clipart.
2. A). Click it to select then drag.
B). Click it then click the increase brightness button on picture toolbar.
3. From scanner, from file and clipart.

A graphic image that is predefined in shape but the user draws it by
selecting it then dragging its size on the screen.

5. A). Select it then choose a different line thickness on the drawing toolbar.
B). Select it then choose a fill pattern from the fill bucket on toolbar.

C). Right click the autoshape then select the Enter text command. Type the
text then click a blank area on the screen to apply.

6. Linking — object imported can only be edited in the original application from
which it was created. Embedding — object imported becomes part of the
current application and can be edited there.

Click it to select it, then drag handles to increase size.
Import from file, from clip gallery and by drawing.

This refers to inserting a picture or clipart from a different application sjgrage
or Internet.

g
Practical activity 1

m Jitegemee Self Help Group is a society of young
entrepreneurs. The Group is in the process of writing a
proposal in order to get funding from one of the NGOs and
the government. The secretary of the Group, Mr. Kagezi has
requested you to type for him a five page handwritten
proposal.

Use the following to create the document outline;
O Introduction

O Executing summary

O Future outlook and trends

O Office equipment and personnel

O Operational plan

O Conclusion

Save it as Jitegemee Plan.
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Practical activity 2

m  Open the an existing document of not
less than ten pages perform the following
operations;

a) Change Title font to Tahoma, bold, 18 points
size and centre it on the page, underline.

b) Drop the first character of the first paragraph
to occupy three lines below it.

c) Insert page numbers at the bottom right and
footers at the centre of page.

267
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Practical activity 3

1. Figure right shows a
drawing done using Word
processing software;

a) Draw the object and
make the outer circle to
have double lines outline.

b) Fill the inner circle with
red colour.

c) Fill the triangle with blue
colour and make it to lie
behind the inner circle.

2. Print two copies of
selected page of
Jitegemee Plan.
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Chapter 4
Spreadsheet
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Introduction

m Spreadsheet is essentially a ledger sheets
that enables the user enter, edit and
manipulate numeric data.

270

135



g
Types of spreadsheets

m Manual spreadsheet — this spreadsheet
consists of a book like ledger with many
sheets of papers divided into rows and
columns on which data elements are
entered manually using a pen or pencil.

m Electronic spreadsheet — this spreadsheet
IS prepared using a computer program that
enables the user to enter values in rows
and columns and manipulate them
mathematically using formulae.

271

" AN
Advantages of electronic spreadsheet

m Entries made using spreadsheet are faster and
accurate.

m |t offers a large area for data entry and manipulation.

m Electronic spreadsheet produces neat and
presentable output.

m |t has better documentation formatting capabilities.

m It has inbuilt formulae called functions that enables
the user to quickly manipulate mathematical data.

m Has ability to perform automatic recalculation.

m |t utilizes large storage space on computer storage
devices to save and retrieve documents.

272
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Examples of spreadsheets programs

m Viscal
m Lotus 1-2-3
m Microsoft Excel

m VP — Planner

273

-

Components of spreadsheet
(Worksheet and Database)

Worksheet
— . m Worksheet — this is the
component in which data
values are entered. It's
made up to of rows and
columns.

m Database — the data
management feature of
spreadsheet can be
found on the data menu.

e sy " Data entered in

| e D T spreadsheet can be

IS e Sl manipulated by sorting,

] s - w——e filtering, calculating
S e subtotals etc.
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Components of worksheet
(Graphs)

Column chart m Graphs —agraphisa
pictorial
representation of the
base data on a
worksheet.

-
=
f_—‘
‘

Tif

------
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Examples of graphs found in MS-Excel

Line chart m Pie chart

£t

m Graphs e.qg. bar,
column

m Line graphs etc.
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Application areas of spreadsheet 1

m Accounting — many accountants and business
people find spreadsheet a useful tool to use in
recording daily transactions and keeping of financial
records. Spreadsheet comes with inbuilt functions
that make accounting tasks easier.

m Data management — spreadsheet enables neat
arrangement of data into tabular structure. Data
management functions include sorting, filtering,
using forms to enter and view records.

m Statistical analysis — spreadsheets have in-built
statistical analysis tools that can speed up data
manipulation. Some of statistical functions found in
MS-Excel are: Average, Maximum, Median,
Minimum, Mode, Sum etc. -

"
Application areas of spreadsheet 2

m Forecasting (“What if analysis”) — this feature
involves changing the value of one of the
arguments in a formula to see the difference
the change would make on the result of the
calculation.

m Scientific application — engineers, scientific and
technical users store empirical data, perform
statistical analysis, build and prepare complex
mathematical models using spreadsheet.

m Home/personal use — this involves tracking
cash flow, preparing household budgets and
personal financial statements.

278

139



- O

Starting Microsoft Excel

Click on the “Start”
menul.

Point to
“Programs/All
Programs”.

Point to “Microsoft
Office 2003".

Click “Microsoft
Office Excel 2003”.

279

Parts of MS-Excel windows

0200
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Title bar

Menu bar

Standard toolbar
Formatting toolbar
Name box (Cell address)
Formula bar

Column header

Row header

Vertical scroll bar
Horizontal scroll bar

. Worksheet tab

Cell pointer
Status bar
Worksheet 280
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Microsoft Excel application window 1

Title bar — it displays the title of the application and control
buttons for minimising, maximise and closing application.

Menu bar — displays a list of menu options e.g. inserts, view,
edit etc.

Standard tool bars — has shortcuts to some of the most
commonly used menu commands e.g. copy, cut etc.

Standard tool bar — has also shortcuts to some of the most
commonly used menu commands e.g. bold, italic etc.

Name box (Cell address) — is the combination of a column
header and a row header the indicate of a specific cell.

Formula bar — it enables the user to enter or edit a formula or
data in a cell.

Column header — indicates vertical direction of the cell. It is
located above the worksheet and lined up in order to the
alphabet.

g

10.

11.

12.

13.

14.

15.

Microsoft Excel application window 2

Row header — indicates horizontal direction of the cell. It is
located left the worksheet and lined up in order to the figure.

Vertical scroll bar — the user drags to scroll upward or
downwards of a worksheet.

Horizontal scroll bar — the user drags to scroll right or left of a
worksheet.

Worksheet tab — shows the number of worksheets in the
workbook.

Cell pointer — it marks the position of the current cell or the
insertion point.

Status bar — displays information about the program currently
running.

Worksheet — consists of cell, rows and columns where data is
entered.

Workbook — it consists of several worksheets. 282
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Other parts of MS-Excel

m Cells — a cell is an intersection between a row
and a column. A column is a vertical
arrangement of cells labelled A,B,C... while a
qo;v:iss the horizontal arrangement labelled

m Active cell pointer — a cell pointer indicates the
curlr_ent active cell. It is highlighted with a dark
outline.

m Cell address — the cell address id the
combination of a column header and a row
header that indicate the location of a specific cell
such as Al, B2, C3 etc.

283
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Navigation the MS-Excel screen 1

B e - -

Epr——a— 1. Click cell D5. notice that
=0 the cell pointer
immediately moves to he
cell and the name box
S P reads D5. typing on the
keyboard now inserts
entries in cell D5 as long
TR gl i as the pointer is still there.
2. Click letter A that heads
the first column. Notice
that the whole column is
sasandd id highlighted.

284
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Navigation the MS-Excel screen 2

o @p

Double click cell E10.
Notice that the insertion
pointer blinks in the cell
and you can start typing
chlallracters inside the
cell.

Click the down arrow on
the vertical scroll bar.
The worksheet moves
upwards on the screen.
The opposite happens
when you click the left
arrow on the vertical

scroll bar.
285

Navigation the MS-Excel screen 3

R e -

Click the right button on the

horizontal scroll bar. The
worksheet moves on the

left. The opposite happens

when you click the left
button on the horizontal
scroll bar.

Press the “right arrow” key

on the keyboard. Notice

that the cell pointer moves
one column to the right on

the same row. This can

also be done by pressing

the “Tab” key once. 2s6
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Navigation the MS-Excel screen 4

R e

W -

Press the “left arrow” key
on the keyboard. Notice
that the cell pointer
moves one column to
the left on the same row.
Pressing “Shift+Tab”
gives the same results.

Press the “up arrow” key
on the keyboard. Notice
that the cell pointer
moves one row up on

the same column.
287

Navigation the MS-Excel screen 5

TPTARTTIEE TN

) gy
®

10.

11.

Press the “down arrow” key
on the keyboard. Notice that
the cell pointer moves one
row down on the same
column.

Press the “End” key. The
status bar will display the
message “END”. If you press
the right arrow key, the cell
pointer will moves right to the
last cell on the row. If the left,
up or down keys were to be
pressed instead, the cell
pointer would move to the
last cell to the left, top or
bottom respectively.

Pressing “Ctrl+Home” moves
the cell pointer to the first cell
of the worksheet i.e. cell AZ2®
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Steps of “Using blank template”

U
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Steps of “Using a template”

New Workbook task pane

On the “File” menu,

Click “New” (New
workbook task pane is
displayed).

In the “New” section,
click “Blank
workbook”. (New
workbook is opened).

NB; shortcut key

Ctrl + N 289

On the “File” menu.

Click “New” (New Workbook
task pane is displayed).

On the task pane under
“Templates”, click “On my
computer” (Template dialog
box Is displayed).

In the templates dialog box,
click “Spreadsheet Solution”
tab.

On the spreadsheets
solutions tab, click the
template that you wish to
create.

Click the “OK” button. 2°°
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Components of a worksheet

B s -
| oasial

detit
B0 TR LLTE DR T T IRy |

A LIST {IF STIGENTS' NECOKS

XTIV ST |

Rt Ll al B
e s e 1 1

IR B 1
_‘:_'_:.:i:'._x

o TR — e - . —
[CNE IR SINIE EP PR N EE-L V) |

-

Entering data into a worksheet

T T —r——
" Johsdiii: _—y 'y
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e _ SISV ™ TV VY |

Cells — an intersection
between a row and
column.

Row — horizontal
arrangement of cells.

Columns — vertical
arrangement of cells.
Range — a group of
rectangular cells that
can be selected and

manipulated as a block.

291

m As you type an entry,

it is displayed in the
formula bar. To place
the content into the
active cell press
“Enter” key, an arrow
key or click into
another cell.

292
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Cell data types

m There are four basic types of data used in
spreadsheet.

OLabels
Values
OFormulae
0 Functions

293
-
Labels
m Any text or
alphanumeric
N characters entered in a
S _'_,__,’,"'_, .:.L.. _:m - cell are viewed as
e labels in a spreadsheet
s program. Labels can
R O IR B B N B T be row and column
i — =i————_  headings used to

describe the contents
of row or column e.g.
class, name, sex etCzes
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Values
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m They are numbers

that can be
manipulated
mathematically e.g.
currency, data,
numbers (0-9) etc.

295

m They are user

designed mathematical
expressions that create
a relationship between
cells and return a value
in a chosen cell.

NB: formula must start

with an = sign.
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Functions

m They are in-built
predefined formulae
that the user can
quickly use instead of
having to create a
new one each time a
calculation is to be
done e.g. SUM,
COUNTIF, IF etc.

297

On the “File” menu
Click “Save as” (Save as
dialog box is displayed).

3. Select the location in which
your workbook will be
saved in the “Save in” box

4. Type a unique name for the
workbook in the “File name”
box.

5. Click the “Save” button.

NB; shortcut key
F12
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Retrieving a workbook

Open dialog box 1

¥
1
H

On the “File” menu, (or
standard toolbar)

Click “Open”.

Click the “Look in” drop
down list arrow.

Select the drive or folder
where the workbook
was saved.

Double click the
workbook icon that you
want and the worksheet.

NB; shortcut key

Closing a workbook.

On the “File” menu.
Click “Close”

This closes the current
workbook but does not
close the application.

NB; shortcut key

Ctrl + F4
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Exiting a workbook

oo ot _yes 1. On the “File” menu.

:):J ._;,,‘ Cirtely J

1=, =P 2. Click “Exit”.

; - :mn.&ti‘v

t 2 '-;:-,u

i : NB; shortcut key

3. e e Prevees

i j :""" ep

; Send Yo .

I — )

301

'_

Block operations

m Performing calculations on a worksheet
data involves block operations. A block of
selected cells in a worksheet is referred to
as a range. A range is specified by the
address of its top left and bottom right
cells or using a name.

302

151



- O

Steps of “select a range of continuous cells”

%= ; 3
@ A LIST OF STUBENTE' NECORDS
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o] e il e S e
1 em————
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N e :
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- e —
| Hum - 1
-:1 - o

-

Click the top left cell
of the range to be
selected.

Hold down the
“Shift” key.

Click the bottom
right cell of the

range (the range will
be highlighted)
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Steps of “select a range of non-continuous cells

.

A LIST OF ETULENTS NEOORDS

e i e e T e

IR ALIE S AR AL

L. A
=
w1
=

N

A LIST OF STUDERTS" WECORRS

T

AT | Do AT T

WA | v

i

al

1.

Click the top left cell
of the range to be
selected.

Hold down the “Ctrl”
key.

Click the bottom
right cell of the
range. “Ctrl selects
individually clicked
rows, columns or
cells.
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Steps of create named range proceed as follows

1. Select the range to
be named.

w— e ™

YT TERE TN T PR

l!,.pn‘mnn.-- E
205 o T Ea

A5 DUOSE RSN (00 BN O 0 IS Ta RS S g L 21

[ A LIST OF STUDENTS' RECORDS Iﬂi 2. Click inside the

- name box. Delete
s i the cell reference
T 7 and type a name for
I e the range.

3. Press “Enter” key to
apply 305

Arithmetic operators

m Arithmetic operators mostly
follow the rule similar to

mathematical concept of

/" |Division =A2/B2 BODMAS. This means that
whatever is in parenthesis is
* | Multiplication |=A2*B2 evaluated first. Multiplication

and division are evaluated
from left to right while

+ | Addition =A2+B2 addition and subtraction are
evaluated last. Left table

- |Subtraction |=B2-A2 shows a summary of
operators used to create
formulae. 306
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Relational operators

= |Equal to =A2=B2

> | Greater than =A2>B2

< |Lessthan =A2<B2

<> | Not equal to =B2<>A2

<= | Less than or =A2<=B2
equal to

>= | Greater than =A2>=B2
or equal to

-

m A relational operator

returns either true or
false depending on
the magnitude of the
value being evaluated.
Table right is
summary of a
relational operator.

307

Operator precedence

Negationasin-1 1
% |Percent 12
o Exponentiation '3
*and/ .Mult:plocanon |2
and division
*and- | Aadttion and s
subtraction
= a» > € <= »= 'Relational ‘6

m If several operators are used

in a single formula, MS-Excel
performs the operations in
the order shown in table right.
A formula with operators that
have same precedence i.e. if
a formula contains both
multiplication and division,
operators are evaluated from
left to right. Enclosing part of
the formula to be calculated
in parentheses or brackets
makes that part to be
calculated first. 308
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Autofill

m You can quickly fill adjacent cells with data
that continues a formula or a series of
numbers, days, dates or etc automatically
by dragging the fill handle.

-
Steps of “Autofill”

il NAME [ENGLISH|MATHITOTAL|A 1.
MARTIN 86 g% 181
STEPHEN 74 100
MARVIN 98 66 | &

i| NAME |ENGLISH |MATH TOTAL{AV
MARTIN 86 a5 181 3.
STEPHEN 74 100 174
MARVIN 88 66 164

arm mMm i ﬁ

309

Select the cell which is
containing a formula or
word or figure.

Place the mouse pointer
bottom right corner of
the selected cell, then
pointer sign will be
changed to black cross.

Move the black cross
pointer up to where you
want to make a copy
using drag and drop.
(down, up, left or right).
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Cell references

m A cell reference identifies a cell or a range of
cells on the worksheet and shows Microsoft
Excel where to look for the values or data
needed to use in formulas. MS-Excel uses the
Al cell reference style that identifies a cell by
its column label followed by row number e.g.
B1, E10 etc. RICI reference style can also be
used where a cell is referenced by its row
number followed by its column number e.g. R3,
C4, R5, C20 etc.

311

'__
Relative reference

[[ NAME TIENGUS; JMATQ';‘_':;;?S?SI m This is a cell reference
.| MARTIN | & | whose cell references

| STEPHEN | 18,100 keep on changing

‘_MARVIN % 5 automatically depending
on their position in the
worksheet e.g. if you

. : — type formula
NAME | ENGLISH MATH MARKS =B2+C2

_ MARTIN 86 95 181 in cell D2 if the formula

U STEPHEN| 74 100-B3+c3 is copied to cell D3 it

.| MARVIN 98 66 | automatically changes to

=B3+ C3.

312

156



" NN
Absolute referencing

L[ SUM [ RANKTIE] | m This is used when you

)| 493|=RANK(M3[$M$3 $M$10) copy a formula to

2| 466 RANK(number. ved_ forder]) )

B o different cell and you

Kl 2a don’t want Excel to
adjust references. To

I TSUM | RANK IF make a formula

) absolute, add a dollar

[ 466]=RANK(MA|$M$3 $1510)

——— ———
| RANC narrbes. ref. [order))

e

sign before the parts of
cell reference that do

7| 451 not change

S e.g. =S A5 x$B$2.

e
-
=]

o
s
o
>

Mixed cell referencing

m This is a combination of relative and absolute
reference
e.g. A3 or A$3
in the first case the column reference is absolute
while the row is relative, in the second case the
column reference is relative while the row
reference is absolute.
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Using in-built functions

m A function must start with an (=) sign followed
the function name and arguments. Argument are
numeric, logical values or text enclosed in
parenthesis. For example, in =SUM(A3:F3),
SUM is the function that adds the range A3 to F3
which is the argument. In MS-Excel, functions
are categorized according to the nature of
problems they work on. We shall look at the
following categories of in-built functions;

O Mathematical
O Statistical

O Logical

00 Date and time

315

g
Steps of “using in-built functions”
of S
= F 1. On the “Insert” menu.
= | 2. Click “function”
== (“Insert Function”
=R dialog box is
N o displayed).
losert Function dialog bax 3. Select the category.
e 4. In the function list
dm= : box, select a
N — function
e - ] 5. Specify the function,,

Avriirmanant thAan AliAl,
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Basic functions and formulae

m A formula is a sequence of values, cell
references, names, functions or operators
in a cell that together produce a new value
while a function is an in-built formula for
solving standard problems.

317

g
Mathematical functions (SUM)

m Add all the value in the selected in the
range of cells. For example if A3, B3 and
C3 contains 20, 50 and 80 respectively,

=SUM(AS:C3)

returns 150.
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Steps of “SUM” function

111 —— . — < "
eV R T W A s LY ]

Select the cell where you
want to return the sum
value.

Click the “Autosum”
command on the standard
toolbar. (formula is
displayed in the cell which
you selected).

Select the range for add the
numbers in a range of cell
using drag and drop. (data
range is displayed in the
brackets).

Type “Enter” key.

319

Mathematical functions (ROUND)

m Rounds a number to a specified number of decimal
places. Zero round off the number to the nearest integer.

For example

=ROUND(49.769,1)

returns 49.8.
while

=ROUND(49.769,0)

returns 50.
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Steps of “ROUND” function

Insert Function dialog box (ROUND)

A s 15

Function Arguments dalog box (ROUND)

0 426871 §
g Bl
wanay|
aodin o J

M ESTIAY
th 1|
4

PA4268TI |
——

1 $11459|
4

10.

Select the cell where you want to
return the round figure.

On the “Insert” menu

Click “Function”.

Type “ROUND” in the search box.
Click “GO” button.

Select a function from the
recommend list.

Click “OK” button.

Click the cell which is the number

you want to round. (cell address
is displayed in the “Number” box).
Type the number of decimal
which you want to round in the
“Num_digits” box.

Click “OK” button.
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Mathematical functions (SUMIF)

m Conditionally add the specified cells
according to the set criteria.

=SUMIF(A3:A10,”>=10007")

returns a value if, and only if, the sum is
greater than or equal to 1000.
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Steps of “SUMIF” functions

Insert function dialog box (SUMIF)

1. Select the cell where you want to
return the sumif value.

2. Click “fx” command on the
formula bar.

3. Select “Math & Trig” category
from the down arrow list.

4. Select a function “SUMIF” from
the list.

5. Click “OK” button.

6. Select the range you want to
evaluate using drag and drop.

7. Type the criteria which is the
condition or criteria in the form of
a number, expression or text that
defines which cells will be added.

8.  Click “OK” button.

323

-

Mathematical functions (PRODUCT)

m Multiplies all the values in the arguments.
For example,

=PRODUCT(40,3,2)

returns 240.

324
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Steps of “PRODUCT” function

Insert Function dialog box (PRODUCT)

Functon Arguments dialog bax (PRODUCT)

ST - ——— - T

.ET;“ e LW )
Sewl.... < P )|

| -
|| s g -

|

D e et LT e
o — — bt -~y

. -

Tar Sa vl l -

"

oo s N

~N

Select the cell where you want to
return the product value.

On the “Insert” menu.

Click “Function” .

Type “Product” in the search box.
Click “GO” button.

Select “PRODUCT” from the
select a function list.

Click “OK” button.

Select the range in the “Number1”
box where you want to multiply
using drag and drop.

If you want to multiply other range,
insert that range in the “Number 2”
box using drag and drop.

10. Click “OK” button.
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Statistical functions (AVERAGE)

m |t returns the average (mean) of a set of
values which can be numbers, arrays or
references that contain numbers e.g. value
20 isin cell B2 and 10 in cell C2 then

= AVERAGE(B2:C2)

returns 15 as the average.
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Steps of “AVERAGE” function

1. Select the cell where you
want to return the average
figure.

2. Click the down arrow of
“Autosum” command on the
standard toolbar.

3. Click the “Average” (formula
is displayed in the cell which
you selected).

4. Select the range for
calculate average using
drag and drop. (data range
is displayed in the brackets).

5. Type “Enter” key.

327

Statistical functions (COUNT)

m Counts the number of cells that contain
values within a range

=COUNT(B2:E7)

returns 4 if all cells have values.

328
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Steps of “COUNT” function

b+ om———. . e
-—me . . cas.sillal

-

Select the cell where you
want to return the count
figure.

Click the down arrow of
“Autosum” command on the
standard toolbar.

Click the “Count” (formula
is displayed in the cell
which you selected).

Select the range for count
using drag and drop. (data
range is displayed in the
brackets).

Type “Enter” key.

329

Statistical function (COUNTIF)

m Conditionally counts the number of cells
within a range that meets a given condition.
For example, if A3, B3, C3, D3 and E3
contain 20, 50, 80, 60 and 45 respectively

then

=COUNTIF(A3:E3,”>50")

returns 2.
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Steps of “COUNTIF” functions

Insert Function dialog box (COUNTIF)

Select the cell where you want to
return the countif figure.

On the “Insert” menu.

Click “Functions”.

Select a category “Statistical”
form down arrow.

Select “COUNTIF” from the list of
functions.

Click “OK” button.

Select the range which you want
to count nonblank cells using
drag and drop.

Type the criteria which is the
condition in the form of a number,
expression or text that defines
which cells will be counted.

Click “OK” button. 331

Statistical functions (MAX)

m Returns the largest value in a set of values
or within a range. For example, if A3, B3,
C3, D3 and E3 contains 20, 50, 80, 60 and

45 respectively then

=MAX(A3:E3)

return the maximum value in the range. In

this case, returns 80.
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Steps of “MAX” function

Select the cell where you
want to return the MAX
value.

Click the down arrow of
“Autosum” command on the
standard toolbar.

Click the “MAX” (formula is
displayed in the cell which
you selected).

Select the range for return
the largest value using drag
and drop. (data range is
displayed in the brackets).
Type “Enter” key. (MAX
value is displayed). 333

Statistical functions (MIN)

m Returns the smallest value in a set of
values or within a range. For example, if
A3, B3, C3, D3 and E3 contains 20, 50, 80,
60 and 45 respectively then

=MIN(AS3:ES3)

will return the lowest value in the range. In

this case, returns 20.
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Steps of “MIN” function

1. Select the cell where
you want to return the
MIN value.

2. Click the down arrow of
“Autosum” command on
the standard toolbar.

3. Click the “MIN” (formula
is displayed in the cell
which you selected).

4. Select the range for
return the lowest value
using drag and drop.
(data range is displayed
in the brackets).

5. Type “Enter” key. 335

Statistical function (RANK)

m Return the position or rank of a number
from a list of values. For example,

=RANK(A2,$A$3:$A$8.1)

returns the position of A2 as if the list was
sorted in ascending order.
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Steps of “RANK” function

Insert Function dialog box (RANK)

P — e
B e e L Y ]

Function Arguments dialog box (RANK)
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-

10.

Select the cell where you want to
return the position.

Click “fx” on the formula bar.

Type the “RANK” in the search
box.

Click “GO” button.

Select a function “RANK” from
the recommended list.

Click “OK” button.

Select the cell which you want to
find the rank.

Select the range of reference
which is an array of, a reference
to, a list of numbers.

Type “1” in the “Order” box if you
want to display descending.
Type “Enter” key. 337

Statistical functions (MODE)

m Returns the most frequently occurring

value in a set of values

e.q. =Mode(A10:E10)
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Steps of “MODE” function.

Insert Function dialog box (MODE)

o Free———
L ppens |

= ®

. — s

{4

Function Arguments dialeg box (MODE)
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Select the cell where you want to
return the mode value.

On the “Insert” menu.

Click “Functions”.

Select a category “Statistical”
Select a “MODE” from the list.
Click “OK” button.

Select the range in the “Number1”
box where you want to calculate
the mode using drag and drop.

If you want to multiply other range,
insert that range in the “Number
2” box using drag and drop.

Click “OK” button.

Logical functions (IF)

m |t returns a specified value if a condition is
evaluated and found to be true and
another value if it's false e.g. IF (mean
score>50,"Pass”, else "Fail”. It will display
Pass. If values are more than 50 else

displays Fail.
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Steps of “IF” function.

Insert Function dialog box (IF)

1. Select the cell where you want to
return the IF value.

2. Click “fx” button on the formula bar.
3. Type “IF” in the search box.

4. Click “GQO” button.
5
6
7

Select “IF” from the recommended list.
Click “OK” button.
Type any formula in the “Logical_test”

) i ' box which is any value or expression

Function Arguments dialog box (IF) that can be evaluated to TRUE or

_ FALSE.

8. Type any words or figure in the
“value_if_true” box you want to display
if value is true. You can nestup to 7 IF
function.

3 9. Type any other words or figure in the
E e e L e | “value_if_false” you want to display if

[Tocren g

value is false.
10. Click “OK”

Date and time functions (TODAY)

m Returns a number that represents today’s
date. The function takes no arguments.
For example, by the time of writing this
book,

=TODAY()

returned 17/05/2012
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Steps of “TODAY” function

Insert Function dialog box (TODAY)

Function Arguments dialog box (TODAY)

- —
Colirs T wrvad Gaie S e 4 A
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e

l‘m:.m
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-

Select the cell where you want to
return the TODAY value.

On the “Insert” menu.

Click “Function”. (Insert Function
dialog box is displayed).

Select a category “Date & Time.
Select a function “TODAY” from
the list.

Click “OK” button. (other dialog
box is displayed which is written
“This function takes no
arguments).

Click “OK” button. (today’s date is
displayed where you select the
cell).

Date and time functions (NOW)

m Returns the current date and time
formatted as date and time. It takes no
arguments. For example,

=NOW()

returned 17/05/2012 08:43
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Steps of “NOW?” function

Insert Function dialoeg box (NOW)

Select the cell where you
want to return the “NOW”
value.

Click “fx” button on the
formula bar.

Type “NOW” in the search
box.

Click “GO” button.

Select a function “NOW” from
the list.

Click "OK” button. (other
dialog box is displayed which
is written “This function takes
no arguments).

Click “OK” button. (today’s
date is displayed where you
select the cell).

Date and time functions (DATE)

m Functions returns a serial number that
represents a particular date. MS-Excel
uses year 1900 serial number 1. for

example,

=DATE(112, 17, 5)

returns May 17, 2012. Year = (1900 +
112), month =5, day = 17
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Steps of “DATE" function

Insert Function dialog box (DATE)
i TAARLRA T

PR —
ot e e e e 20 0 o b >

=0 |
(‘]‘;m }.
e gl

Function Arguments dialog box (DATE)

-

Select the cell where you want to
return the DATE value.

On the “Insert” menu.

Click “Function”. (Insert Function
dialog box is displayed).

Select a category “Date & Time”.
Select a function “DATE”.

Click “OK” button. (Function
Arguments dialog box is
displayed).

Type “Year”, “Month” and “Day” in
the each box.

Click “OK” button. (Date is
displayed in the cell where you
selected).

Date and time functions (HOUR, MINUTE or SECOND)

m Functions returns the current hour as
number 0 to 23, minute from 0 to 59 and
seconds from 0 to 59 respectively.
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Steps of “delete worksheet range”

Select the cell or range
of cells.

On the “Edit” menu.
Point to “Clear”.

Click “All”, “Formats”,

“Contents” or
“Comments”.

NB; alternatively press the

“Delete” key if you want
to delete contents. 34

Steps of “copy and paste cell(s) contents”

NB;

Select the range of cells
On the “Edit” menu

Click “Copy” or “Copy” command
on the standard toolbar.

Click the cell from where you want
the content to be copied.

On the “Edit” menu

Click “Paste” or “Paste” command
on the standard toolbar.

shortcut key for copy
Ctrl+C
shortcut key for paste
Ctrl +V
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Steps of “cut and paste cell(s) contents”

= = ¥
o T 1.

Select the range of cells.

Click “Cut” command on
the standard toolbar.

Click the cell from where
you want the content to
be moved.

Click “Paste” command
on the standard toolbar.

NB; shortcut key for cut

Ctrl + X

Steps of “insert a new column or row”

1.

Position the pointer
where the new row
or column wiill
appear.

On the “Insert”
menu.

Click “Rows” or
“Columns”
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Steps of “delete a column or row”

1. Select the column or
row to be deleted.

2. On the “Edit” menu.

3. Click “Delete”

r

EERERED 18
’ .l.l‘..
I Tiibpye
il
| | | "
ARG

EE

- O

Steps of “insert more worksheets”

1. On the “Insert”
menul.

2. Click “Worksheet”.

(a new worksheet is
- added into your
B workbook.

A LIST UF STUDENTSE" KECORY
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] | e (TR T T S AR BRI
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Steps of “delete a worksheet”

1. Click the
“Worksheet” tab
which you want to
delete.

2. On the “Edit” menu.

3. Click “Delete Sheet”.

Find and replace

m MS-Excel provides capability to find and
replace data in a worksheet same as MS-
Word.
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Steps of “Find” function

mygyesienany
! ili i

- O

On “Edit” menu.

Click “Find”. (Find and
replace dialog box is
displayed).

Type the text to search
for in the “Find What”
box.

Click “Find All” or “Find
next”.

NB; shortcut key

Ctrl+ F

Steps of “replace” function

4.
et b g
= '
|| Potmw ]
] Poses iz | 5.
copm s ||

|

C_B]|
}

On “Edit” menu.

Click “Replace”. (Find and
Replace” dialog box is
displayed).

Type the word or phrase to
find in the “Find What” box.

Type the word or phrase to
replace the found word or
phrase in the “Replace
With” box.

Click “Replace All” or
“‘Replace”.

NB; shortcut key

Ctrl + H
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Steps of “correcting spelling mistakes”

1. On the “Tool” menu.

2. Click “Spelling”
(Spelling dialog box is
displayed).

3. Click a button. Ignore
Once, Ignore All, Add to

= Dictionary, Change,
K Change All or

’ = AutoCorrect.
——— e . NB; shortcut key

| Y =~ By F7

1. Highlight the cells that
have the text to be
formatted.

2. On the “Format” menu.

Click “Cells” (Format

—— ' Cells dialog box is
displayed).
TEREMMEO °'a'°€_':_‘_’x 4. Click the “font” tab.
P gy s 5. Select tlhe type of font,
T ) g font style, size,
e P e underline, color and
= e g other effects.

s 6. Click “OK” button.
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Steps of “formatting numbers”

e e
' S LA At A
D VAR EARS A
L - .
) LIST (@ sTIDNN

Highlight the cells that
have the numbers to be
formatted.

Click the “Format” menu.
Click “Cells”. (Format
Cells dialog box is
displayed).

Select the “Number” tab.
Select the type of
number from the
category list.

Click “OK” button.

Types of formatting numbers

Number Meaning

General General format cells have no specific number format.

Number Used for general display of numbers e.g. 2345.23.

Currency For displaying general monetary values e.g. $100, Ksh.10.

Accounting | Lines up the currency symbols and decimal points.

Date Displays date in chosen format.

Time Displays time in chosen format.

Percentage | Multiplies the value in a cell with 100 and displays it as %.

Text Formats cells to the treated as text even when numbers are
entered.
Custom For a number format not predefined in MS-Excel, select

custom then define the pattern.
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Steps of “formatting borders”

1. Highlight the range you wish
to insert borders.

. On the “Format” menu.

3. Click “Cells”. (Format Cells
dialog box is displayed).

4. Click the “Border” tab.
Select a style of line and
color from the list.

6. Click any commands which
you want to draw the line.

7. Click “OK” button. (selected
range will have a border
around it).

J

Steps of “resize a column with mouse’

1. Move the mouse pointer to
the right hand side line that
separates the column

T De—— headers for instance e.g. the
: P el line between A and B.
2. Notice that the mouse pointer
changes from a cross to a
double arrow.

3. Click the mouse button and
hold it down so that you can
now resize the width of the

: column by dragging it to the

L ————c—— o—— ] . size you wish. After dragging

to the required point release
the mouse button. The
column will have a new size.
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Steps of “resize a column using the “Format” menu

Column width dialog box

Column Width

- O

Select the column
where you want to
resize.

On the “Format” menu.
Point to “Column”.

Click “Width”. (Column
Width” dialog box is
displayed).

Type a width in the
column width box.

Click “OK” button.

Steps of “change row height”

I e

Point to the line that
separate two row
numbers e.g. the line
between 1 and 2. The
mouse pointer becomes
a double arrow.

Drag the line until the
height of the row is as
required, then stop and
release the mouse
button.
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Steps of “auto adjust a column width and row height

poaw §

TR s  fm
A LIST OF STUDINTS  RECORSS
T30 TTAT

ol e El =

Steps of “Inserting

o+ ¢ o R M WACTITE W TR —
i~

Place the mouse pointer
between columns or
heights which you want
to adjust. (mouse
pointer changes from a
cross to a double
arrow).

Double click there.
(width or height was
changed a new size).

rows”

Select the cell where
you want to insert
the row.

On the “Insert”
menu.

Click “Rows” (new
rows was inserted
above of the cell
which you selected
and shift all the other
rows downward).
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Steps of “Inserting columns”

Select the cell where
you want to insert
columns.

On the “Insert”
menu.

Click “Columns”.
(new column was
inserted left of the
cell which you
selected and shift all
the others to the
right).

Steps of “select a entire worksheet”

e sawios oo
L T e ¥ ‘l"
RN T S —

Select the any cell.

Pressing “Ctrl + A”
(whole worksheet
was highlighted).
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Steps of “using autoformat”

e
e 1. Selectarange e.g.
L = JSgfiniy A2:N10 to set an
1 = autoformat.
| 2. On the “Format”
| em——— = menu.
Aiito ek dlélog o 3. Click "Autoformat”.
- - (AutoFormat dialog
el =P box is displayed).
E“‘I"‘; e | 4. Select a autoformat
= | from the list.
eEEn o tees] 5. Click “OK” button.
" BN

Data management

m Sometimes worksheet data can be too
large and make it difficult for the user to
properly manage it. MS-Excel has tools
and features which enables the user to
manage their data.

372
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The feature includes

m Sorting — with this feature spreadsheet can sort
information by row or columns alphabetically or
numerically in ascending or descending order.

m Subtotals — MS-Excel can automatically
summarize data by calculating subtotals and
grand total values in a list.

m Forms — this is a specially prepared template
that the user can use to enter data is a
worksheet.

m Filtering — it’s a quick and efficient method of
finding and working with a subject of data in a
list. In MS-Excel there are two filtering
commands. 373

" S

1. Position the cell
pointer in any cell
containing data.

2. On the “Data”: menu
3. Click “Form” (dialog
box is displayed).

4. Navigate through,

add new, delete or
find records.

L 5. Click “OK” button.
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function

. Select any sell where you wish
sort by clicking its column
header letter.

. On the “Data” menu.

. Click “Sort”. (Sort dialog box is

displayed).
' 4. In the “Sort by” section, select
T e the field for sorting.
5. Select the sort order
Sod:disiogbox: descending or ascending.
= o 6. Select the field for sorting and
a-  H==ls sort order if you want to set
= = more.
=R 7. In the “My data range has”
- o] e [B) section, select “Header row” or
e ar SO “No header row”.

8. Click “OK” button.

Types of filtering in a MS-Excel

m Autofilter — uses simple criteria and
includes filter by selection. Autofiltering
can be applied to only one list on a
worksheet at a time.

m Advanced filter — use more complex
criteria.

376
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Steps of “Autofiltering a list”

' T F—mw ) _
el | == lra 1. Select a cell in the list
e where you want to set an
A T T4 autofilter.
R 2. On the “Data” menu.

3. Point to “Filter”.

4. Click “Autofilter”. (down
arrow buttons are
displayed in the header

2] e [ = row of data range).
e . 5. You can sort or display
W o = ) R U any data from the list.

Steps of “using custom autofilter”

S R—— 1. Click the down arrow
R button. (the list is
displayed).
2. Click “Custom”.
(Custom Autofilter
Custom AutoFilter dialog box dialog box is
i (. STUDENT -g; displayed).
i 5 o 3 3. Custom for filter as
] = you want.
| A 4. Click “OK” button.
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Subtotals and grandtotals

e bt b T A S A A e
e > >

m Subtotals function is used

to summaries a
worksheet list to display
grouped subtotals and a
grand totals. The list is
grouped using a preferred
field. In MS-Excel to
insert subtotals, you first
sort the list so that the
rows you want to subtotal
are grouped together.
Figure right shows a
subtotaled list.

Sort the data in ascending or
descending order.

Select a cell in the list.

On the “Data” menu.

Click “Subtotals”. (Subtotal dialog
box is displayed).

In the “At each change in” box,
select the field to use for grouping.
In the “Use function” box, select a
function you want to use.

In the “Add subtotal to” box, check
the columns that contains values
you want to calculate subtotal in
the check box.

Click “OK” button. (MS-Excel
automatically the list by calculating
subtotal and grand total values of
the list).
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Input validation

m To ensure that a user does not enter
invalid data, set the validation criteria. An
error message is displayed when data that
violates this rule is entered.

-

Steps of “set data validation” 1
= =

= 1. Highlight the range

of cells to validate.
2. On the “Data” menu.

3. Click “Validation”.
- (Validation dialog
Data Validation dialog box (Setting tab) b oX | S dl Spl aye d)

oy 4. Click “Setting” tab.
i = 5. Select a validation
| = |® criteria each boxes.
= e
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Steps of “set data validation” 2

Data Validation dislog box (Input Message)

| Cepe— - [

Charts / graphs

10.

11.

12.

Click the “Input Message”
tab.

Type the title and message
in the each box.

Check “Show input
message when cell is
selected”. If you want to
display.

Click the “Error” alert” tab.
Select the style of error
alert from the list.

Type title and message in
the each box for error alert.

Click “OK” button.

m These are pictures that represent values
and their relationships. A chart helps the
reader to quickly see trends in data and be
able to compare and contrast aspects of

data.

384
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Types of charts

MS-Excel charts

— :
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=

Line chart
Columns chart
Bar chart

Pie chart
Scatter chart

NB; Figure right shows
more types of charts
available in MS-Excel.
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Steps of “generate a chart” 1

Chart wizard dialog box (Chart Type)

Source Data dialog box

N . w4

1. Click “Chart wizard”

command on the standard
toolbar. (chart wizard dialog
box is displayed).

Click “Standard Types” tab.

Select the chart type from the
list.

4. Select the chart sub-type

from the list.

5. Click “Next” button.
6. Click “Source Data” tab.
7. Select the data range using

drag and drop.

8. Select series in “Rows” or

“Column”.

9.  Click “Next” button.
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Steps of “generate a chart” 2

Chart Wizard dialog box (Chart Option)

S T |~ — L
'] o - - - e

| R

| S PELS

\

' S i

Chart Wizard dialog box (Chart Location)

¢ RS
[t ottt Compmgm gy b
|

e
] s D

N !’ ® s g

1

| m - S =

- O

10.
11.

13.
14.

15.

Click “Title” tab.

Type the name of chart
title, X axis and Y axis in
the each box.

Click other tabs if you
want to add.

Click “Next” button.

Select place the chart
“As new sheet” or “As
object in”.

Click “Finish” button.

Editing and formatting charts

Chart in edit mode

s (I ST

—— e

it

Once the chart is
created, its data
series patterns or
colours, size, location
and orientation can
be changed. Once
you select the chart, a
“chart’” menu item is
added onto the menu
bar as shown in figure
right.
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Steps of “label a chart”

e

1. Right click on the chart.
(shortcut menu is
displayed).

2. Click “Chart option”.
(Chart option dialog box
is displayed).

Click “Data label” tab.

4. In the “Label Contains”
section, check you want
to display.

5. Click “OK” button.

Steps of “inserting titles”

e 1. Right click on the
== chart. (shortcut
menu is displayed).
2. Click “Chart option”.
(Chart option dialog
box is displayed).
Click “Title” tab.

4. Type name of chart
title, X axis and Y
axis in the each box.

5. Click “OK” button.
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Steps of “inserting a legend”

m
ot ot i g

Ty

Steps of “changing the chart location”

F

_a
s - JAA.. ——dndd o d

row

1.

Right click on the chart.
(shortcut menu is
displayed).

Click “Chart option”.
(Chart option dialog box
is displayed).

Click “Legend” tab.
Check “Show legend”

Select the place of
legend bottom, corner,
top right or left.

Click “OK” button.

Right click on the
chart. (shortcut
menu is displayed).
Click “Location”.
(Chart Location
dialog box is
displayed).

Select the place of
chart where you
want to display.

Click “OK” button.
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Steps of “changing the chart type”

1. Right click on the chart.
(shortcut menu is
displayed).

2. Click “Chart Type”.
(Chart Type dialog box

is displayed).
3. Click “Standard Types
tab”.
4. Select the type of chart
— from the list.
5 Eﬂﬂ 5. Select the sub-type of
= v chart from the list.
o 6. Click “OK” button.

- O

Steps of “Print preview and page adjustment” 1

Print previaw button on the standard 1ol bar

P ——— 1. Click “Print Preview”

s e command on the

R R standard toolbar.

' (print preview
window is displayed).

2. Click “Setup”
command. (Page Set
up dialog box is
displayed).
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Steps of “Print preview and page adjustment” 3

Page Setup dialog box (Page tab)

T ——) 3. Inthe “Page” tab, you
e can set “Orientation”
o and “Scaling”.

4. In the “Margins” tab,
you can set each

@~ - margins.

-

Steps of “Print preview and page adjustment” 3

Page Setup dialog box {Header/Footer tab)

F 5. In the “Header/Footer”

| tab, you can insert some

st data e.g. characters,
= ' page number, picture or
—_— etc which you want to
—— display.
Page Setup dialog box (Sheet tab) 6. Inthe “Sheet” tab, you

can set print area, title,
order and other options.

e ' 7. Click “OK” button.
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Steps of “Print from print preview window”

Print preview window

1. Click “Print” command.
(Print Preview window is
closed and Print dialog
box is displayed).

2. Select the printer from
the down arrow list.

3. Select other options
“Print range”, “number
of copies” or etc.

4. Click “OK” button.

In creation of charts there must be

m Data range — this is a rectangular block of
cells that provides the base data that is
used to create the chart.

m Label — each representation of data on a
chart can either be labelled by a value or
text.

m Legend — this is a key that explains what
each colour or pattern of the data
representation in the chart means.

398
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Review gquestions 1

Define a spreadsheet.

What is an electronic spreadsheet?

State four advantages of an electronic spreadsheet over:
A) Manual spreadsheets.

B) Electronic calculator.

Explain three components of a spreadsheet.

State five application areas of spreadsheets.

What is forecasting? How can a spreadsheet help a person to do this?
Give any two methods you can to start MS-Excel.
Differentiate between a formula and a function.

Write the following formula as absolute =F10+G20.

10. The formula =A1+C2 is initially typed in cell D1. what will it be when copied
to cell E1?

11. Differentiate between a worksheet and a workbook.

12. How can you close a MS-Excel worksheet without exiting from the
application? 399

© ® N o O M

"

Answer of review questions 1-1

1. Aledger sheet is made up of rows and columns for entering/writing data.

2. A computer software that looks like the manual ledger sheet with rows and
columns used for entering data and manipulating numerical data.

3. A). Manual spreadsheet.

1. Electronic spreadsheet has large worksheet as compared to manual
worksheet.

2. Electronic spreadsheet has inbuilt formulae called functions that are
nonexistent in manual worksheet.

3. Electronic spreadsheet uses the power of the computer quickly carry out
operations.

4. Superior formatting and editing qualities of electronic spreadsheet make
it better than the manual worksheet.

B). Electronic calculator.
1. Has more memory than a calculator.

2. Able to perform more complex and even logical operations but a
calculator cannot.

3. Uses large storage capacity of computer that a calculator doesn’t have.
4. Large work area that a calculator does not have. 400
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Answer of review questions 1-2

Worksheet, database and graphs

5. Scientific applications, accounting, forecasting, data
management and mathematical operations.

Predicting future trends using the goal seek command.
A). Double click the shortcut icon on the desktop or.
B). Select MS-Excel from the programs menu.

8. Formulae — arithmetic and user developed while
functions — inbuilt formulae. Some of them are macro

functions.
9. =$F$10+$G$20
10. =B1+D2

11. One page in a workbook is called a worksheet.
12. Click the File-close command.

401

g
Review questions 2

1. State the effect of pressing each of the following key combinations on the
cell pointer:

A) Right arrow key
B) Shift + Tab
c) Ctrl + Home
2. Define each of the following:
A) Cell
B) Row
c) Column
3. Write the equivalent R1C1 reference for G20.
What is a name reference? How can you accomplish this in Excel?

5. What is a template? Explain how can start a spreadsheet template in MS-
Excel.

State four data types acceptable to spreadsheets and explain each of them.
Differentiate between single and multiple cell referencing.
What is a range? 402
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Answer of review questions 2

A). Moves cell pointer to the cell on the right.
B). Moves cell pointer to the cell on the left.

C). Moves cell pointer to cell Al

A). Intersection between row and column.

B). Horizontal arrangement of cells.
C). Vertical arrangement of cells.
R20C7

It is a cell reference that is a name. To name a range, select it then type a
name in the name box then press enter key to apply the name.

A pre-formatted worksheet document used as a master layout for others. To

start a template:
i. Click File-New command.

i. Inthe new dialog box click the spreadsheet solutions tab then double click the

template that you wish to start.
Values, Labels, Formulae, Functions.

Single referencing — for one cell, e.g. A1 while multiple referencing — for

many cells, e.g. A1:B3
A group of rectangular cells.

-

403

Review questions 3

m Match the following
statements with the
correct answers.

(@) Click this to reduce the A Name box
MS-Excef windows size to an
icon on the task bar

(b). Displays the current/active ‘B Save command
cell address

(c). Saves the file without ‘C. Minimize button
changing its current address
and name

(d). Location where you can 'D. Formula bar
edit the contents of a cell

404

202



"

Answer of review questions 3

a. C
b. A
c. B
d D

405

Review questions 4

1. Differentiate between the following
terms:
A) Formula and function.
B) Relative and absolute cell referencing.
C) Relational and arithmetic operators.
D) DATE() and TODAY/() function.

2. The formula $A1 + B$1 was entered cell
C1. How would the formula be, if copied
to F27?

406
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Answer of review questions 4

1.

2.

Differentiate

A) Formulae are mathematical expressions while a
function is an inbuilt formula.

B) Relative reference adjusts to reflect the new location
while absolute reference do not change.

C) Relational operators returns a boolean value (True
or False) while arithmetic operators are used for
performing basic arithmetic operations.

D) DATE() returns serial number that represents a
particular data while TODAY () returns a number that
represents today date.

$A2 + ES1L

407
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Revision questions 1

. Describe two ways to complete an entry into a cell.

How does MS-Excel determine that an entry is a text or
a formula?

How do you clear (erase) the contents of a cell?

. How can you copy a formula?

Explain how you can print a worksheet in landscape
orientation.

6. How can you insert rows in a MS-Excel worksheet.
7. Differentiate between copying and moving data in a

worksheet.

8. What is the autoformat feature?
9. Explain the term filter. How is a filter different from a hide

command.

10. Why are forms needed in MS-Excel. 408
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Answer of revision questions 1-1

1. A). Select a cell then type from the keyboard OR.

B). Select a cell then double click the formula bar and type the

value in the bar.

2. Formulae have equal sign at the beginning while text has
either letters or a combination of letters and numbers.

Select cell then press delete key on the keyboard.

4. Click the cell that has the formula then click the Edit-Copy
command. Click the cell to copy to then click the Edit-Paste
command.

5. 1). Click File-Page setup command, choose landscape.

2). On the margins tab of the page setup dialog box, select the
page orientation then click OK button.

3). Send document to printer. 409

"
Answer of revision questions 1-2

6. Click the Insert-Rows command.
7. Copying — makes duplicate of data.

Move — relocates data from one section of
document to another.

8. A feature that applies a pre-formatted feature
on a selected range of the worksheet.

9. Afilter hides all the rows that do not have a
particular selected value in a column while
hides the entire row/column.

10. A). A form helps users to enter values in a table
with minimum errors.

B). It hides the base data of the table hence ,,
enhances data sectiritv
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Revision guestions 2

Give two examples of charts that you know.
Why are charts important in a spreadsheet?
Explain the concept of subtotals.

What is sorting? Explain how you can sort data in
ascending order.

Give three number formats in MS-Excel.

6. What re worksheet borders? Explain how to implement
them in the worksheet.

7. What is the difference between printing a range and
whole workbook.

8. Explain two ways of changing the font size in MS-
Excel.

9.  Whatis alegend?
10. Which chart type will be most suitable to show trends#*

P w DN PR

o

Answer of revision questions 2-1

1. Pie charts, line charts, bar charts, scatter charts, column
charts.

2. A chart represents sets of data in pictorial form hence
makes the data easier to understand and interpret.

3. Subtotals command groups and finds totals of similar
data records in the spreadsheet.

4. Sorting is arranging data values in a particular order.
a. Highlight data range to be sorted.
b. Click Data-Sort command.

c. In the sort dialog box, select the order of sort in the
key field as ascending then click OK.

5. Number, text, fraction, currency, scientific and time etc.
412
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Answer of revision questions 2-2

6. Are printable borders inserted around cell borders.
6. Select the range then click Format-Cells command.
On the Borders tab, select the border styles then click

7.

OK to apply.

7. Print range — print a selected workbook group of cells in a
worksheet.

Print whole — print the entire workbook that has data.

8. A). Highlight range then select font size from formatting
toolbar.

B). Highlight cell, click format — cell — Font — Size — Adjust.

9. Is a key that shows the meaning of different data values in
a graph that are usually represented by different colours.

10. A line chart.

g

Practical activity 1

Row | Label Value

1. Rent 650

2. Utilities 13,200

3. Salaries 15,700

4, Loan 1,700
repayment

5. Insurance 1,040
policy

6. Office supplies |12,000

7. Fixed costs 44,290

413

Study table right and
enter its values in a
worksheet.

Save the worksheet as
My Budget.

Select the range i.e.

from top to bottom and
press delete key on the
keyboard.

Click Edit — undo to
reverse the delete at'tion.
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m Using the grading
system given below,
create a worksheet
that can be used to
calculate end of term
examination marks
and assign grades
based on the
following grading

system:

save the workbook as
Exam Grades.

Practical activity 2

80-100 A
70-79 B
60-69 C
50-59 D
40-49 E
Below 40 | Fall

-

31 | Barclays bank
|31 |kca

.3:‘1 '.:amee-s.S::rs
|31 |15 Pubteners
[an M Alen

[an ‘B\’.:symcm

.3»'1 .Concua siabonanes

[3n [A Wirters
'313 'Ie-t boak canter
|z |88 Progores

| e | Drarnond systems

Practical activity 3

Loan payment | 1.000
| Sanings | 800
[Rert ['t.000

|'sch Magazines | 870
[ Satarnes 200
[ Selanes I a50
.Cmce suppliers [ 225

Saanes 995

| Book suppies |'s00
[ Matenaks 330
[Comouters | 7.700

415

Prepare the
following worksheet.

Save the worksheet
as Account.

Calculate the total
amount.

Print the worksheet
on landscape
orientation.

416
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Practical activity 4

Financial comparison for October 2011.

MIWANI ENTERPRISES.

1. Save the worksheet as Miwani.

2. Add up the total for:
A Income; and

B) Expenses on the budget column.

3. Get the surplus (profit or loss) in both columns by
subtracting the Total Expenses from the Total

Income.

4. What is the difference between Actual transaction
and the plan (Budget). Get the difference by
subtracting Budget surplus form Actual surplus.

- O

Practical activity 5

1-Mar |880 |975 1045 |1176 |730 | 1035
8-Mar |1440 885 1045 1140 | 1350 1440 |

15-Mar 800 |900 1040 | 1356 | 1400 1210 |

417

m  Enter the following data
for 3 weeks’ sales in a
bookshop.

A)

B)
)

D)

Save the worksheet as
bookshop sales on your
computer.

Get the totals.

Draw a bar graph that
compares values for the
week starting 15" march
and save it on a separate
worksheet.

Create a pie chart that
compares the sales for all
the three Wednesdays.
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Chapter 5

Database

419

-

Introduction

m A data base is a collection of data stored
in a computer system in some organised
manner to make the retrieval of the data
easy.

420
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Database concepts 1

m Traditionally filling methods

OThis is the old way of organising files. This
method is where data is stored within a single
paper file or table.

421
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Database concept 2

m Computerised database

OThis database use database management
system software to manipulate data.
Examples of DataBase Management
Software (DBMS) include:

= MS-Access
m Oracle

= Fox Pro

m Dbase IV

422
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Disadvantages of traditional methods

m Unnecessary duplication of data.

m Boredom and time wasting while
searching for a record.

m Misleading reports due to poor data entry.

m Poor update of records.

423

'_
Functions of DBMS

m Allow the user add or delete records.
m Update or modify existing records.

m Organise data for easy access, retrieval
and manipulation.

m Ensure security for data in the database.
m Keeps statistic of data items in database.

424
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Database models 1

Flat files

Admizsion number |49
Tosak marks fHeo
Number of subjecss | 10
ASrage &8
Postion 4

Hierarchical data base model

L]
il
Petr
z ~. -1
Laved 1 Lowsi s Loved 1
|ty 2oy Jxea ey | ety Roen)

Flat files — this model of
database holds only one
set of data and is not any
different from the manual
files e.g. the library
catalogue.

Hierarchical model — in
this model items are
arranged in hierarchical
(tree) form. To access
level one data items, you
have to first access level
one data items. A specific
single path leads to each

item at lower levels.
425

Database models 2

Network database model

Canteen|
S/ S
[Customers|
:
\

Relational database model

500 Mary Kosch | 0R078507
23 | Pater Karlri | 0867596
{40 Dot Moo DM4S5000

%00 |20 |232004 | 50000
450 811 252009 5000
450 E2] [352004 13000
40 057 362004 1300

Network model — in this model,
lines are used to express the
relationship between different
data items, forming a network
of items. Access of one item
can be through many paths
and from any item.

Relational model — in this
model, related data items are
stored together in structures
called relations or tables.
Relationship can be created
between tables such that a
record or records from one
table relates to another in
another table.

426
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Database models 3

m Object oriented model — in this model,
database is a complete program built to
hold a collection of objects, which have
both properties and behaviour.

427

'_
Features of database 1

Tables/file structure

m Tables/file structure —
this is database
structure that is used
to hold related
records.

m Queries —thisis a
i:::{ Farmer Number, Name, Month of Delivery tOOI used to Search
were for or question a
Month of Delivery = “January” database on SpeCIfIC

records.

Queries

428
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Features of database 2

Sample form
5 e | m Form/Screen input — this
[ tuwei0 o Is a graphical interface
e that resembles the
b Lt ordinary paper form used
§ Ao n| 1000 00

T 4 to collect data. It enables
. the user to view and enter
Sample report data into a table.

m Report — database
provides the user with a
tool for generating reports
from a table or query.

-— - 429

'_
Features of database 3

m Modules — this tool is like the macro but
it's more precise in the sense that you
have control over the actions taken.

m Macro — this tool enables the user to
automate frequently performed procedures
or tasks.
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Data organisation in a database

m Field — this is a character or a logical
combination of characters that represent a
data item e.g. in a class list the Admno is a
field.

m Records — this is a collection of related fields
that represents a single entity e.g. student
name, sex, age, marks etc.

m File — this is a collection of related records.

m Database — this holds all related files or
tables. 431

-

Creating a database using MS-Access

Click “Start”.

Point to “Programs/All Programs”.
Point to “Microsoft Office”.

Click “Access 2003” (application is
opened).

5. On the task pane, click down arrow

sign of click “Getting Started”
(shortcut menu is displayed).

6. Select “New file”.

7. Click “Blank database” (File New
Database dialog box is displayed).

8. Select the location where you want
to create the database from the
arrow down list.

9. Type the name of database in the
file name box.

10. Click “Create” button.

Eal A

ffeje v ek
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Microsoft Access screen layout

= O

Steps of “exiting from Access”
1. On the “File” menu.
2. Click “Exit.

NB: shortcut key
Alt+F4
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Steps of “creating a table structure” 1

S
1. Click “Table” tab.

ol 2. Click “New”. (New
|2 Table dialog box is
I displayed).

New Table diaiog box 3. Select “Dgsign View”
from the list.

tm_;;i 4. Click “OK” button.

(Table is displayed).

- O

Steps of “creating a table structure” 2

-

5. Type a unique name
..... for each field in the
table.

i

r 3

e —

L[ O
? i i

i
1%'

6. Select “Data Type”

ﬁa: from the down arrow
= & list.

el 7. Add the other fields.
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Steps of “creating a table structure” 3

Save As dialog box

8. After you add in other
fields, click “Save”
button on the standard
toolbar. (Save As dialog
box is displayed).

9. Type the name of table
in the “Table Name”
box.

10. Click “OK” button.

- (Message box is

e e displayed).

: = s = | 11. Access will ask you
whether you want to
create a “Primary Key”,
click “Yes”.

Rules of a filed name in the table

m A field name must start with a letter and
can be up to a maximum of 64 characters
including letters, numbers, spaces and
punctuation.
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Field data types 1

m Text — it includes alphabetic letters, numbers,
spaces, punctuation etc. This data type is used
in field that needs no calculations.

m Number — this field is made up of numeric
numbers 0-9 that are to be manipulated
mathematically.

m Memo — this is made up of alphanumeric data
used if you need to enter several paragraphs of
text.

m Data/Time — identify a field either as date or timgg.

g
Field data types 2

m Currency — identify a numeric value that have
decimals or fractions used when dealing with
monetary values.

m Autonumber — it's a numeric value used if you
want MS-Access to automatically increment the
values in the field.

m Yes/No — it’s a logical field where an entry is
either a “Yes” or “No” “True” or “False”. Ole
object — this data type is used with graphical
user interface application for inserting graphical
objects.

440
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Field properties settings

m As you create more and
more complex tables, you
will find a need to use field
properties to specify finer
details related to fields and
table entries expected. Field
properties depend on the

e type of field selected. For
example, when you click on
a “Text” field, then the
“General” tab, you will see
properties associated to text
data type as shown in figure
right.

Table properties settings

g
Field properties 1

m Field size — allow the user to set the number
of characters in a field instead of the default
50 for text fields. For numeric fields integer,
bytes, single, double or long integer is used.

m Format — determines how information
appears on the screen and when printed e.g.
you can format number to scientific,
currency, % etc

442
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Field properties 2

m Decimal places — for number or currency

fields you can specify the number of
decimal place.

m Input mask — it automatically formats the
field entry into specified format e.g. a
number 02042426090 and the input mask
Is set as 000-(0000)-(0000) it will
automatically display as 020-4242-6090. _,

g
Field properties 3

m Caption — it's a more descriptive name for
a field to be used in a table or a form

display e.g. a caption Fname could be
First name.

m Default value — this is a value that will
appear automatically in the form if nothing
is entered by the user to change it e.qg.
Date () automatically displays current date,
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Field properties 4

m Validation rule — it’s a logical expression
that restricts values to be entered in a field
e.g. to restrict value entered in a field to be

between 0 and 100 type > = 0 and < = 100.

m Validation text — this is message that
appears once the validation rule is violated
e.g. you may enter a validation rule for the
above rule to display “Enter a number
between 1 and 100"

445
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Field properties 5

m Required — Determines if an entry must be
made in the field before you proceed to
the next field or record.

m Allow zero length — allows the user to
proceed without making any entry in the
field set as zero length.

446
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Field properties 6

m Indexed — it facilitates the organisation of
records for easy search.

m Primary key — it's a field that enforces
uniqueness in a table so that one record is
not entered twice.

m Index — this is a feature used to speed up
search and sort operations in a table.

447

gt
Primary key and indexes.

m An index is a key(s) used to speed up searching
and sorting records in a table, while a primary
key is an index that uniquely identifies each
record stored in the table. A primary key
prevents the user from making null or double
entries into a table. Access uses the primary key
to order records, and control redundancy. Once
a field is set as primary key, the datasheet in
automatically indexed or sorted using the
primary key.
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Steps of “set a primary key”

—c
Sar R

1.

Open the table in
design view.

Select the field you
want to set as the
primary key by
clicking in the row
header to the left the
“Field Name”.

Click “Set Primary
Key” button on the
tools bar.

Steps of “set another field as an
index other than the primary key”

Indexes dialog box

1.
2.

Open the table in design view.

Click “Indexes” button next to
the primary key. (Indexes
dialog box is displayed on the
screen as shown in figure right
above.

In the “Index Name” column,
type the name of the index.

In the “Filed Name” column,
select the corresponding
fieldname.

In the “Sort Order” column,
select “Ascending” or
“Descending”.

“Close” dialog box.
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Steps of “adding new records”

K

UHHHEE

Double click the
table icon. (the table
Is displayed in
datasheet view”.

On the “Insert”
menu.

Click “New Record”.

m An arrowhead indicates

that no new data entry or
edit is pending.

Asterisk symbol marks a
blank record below the
current entry.

Pencil symbol indicates
that the current record
entry is not yet saved.

Record locked indicates
that the current record is
being edited by another
user in a multi-user or

networked environment.
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Steps of “deleting records”

1. Click the record you
want to delete.

On the “Edit” menu.

Click “Delete”.

Steps of “editing fields”

1. Double click the field
you want to edit.

2. Replace the cell
content.
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Steps of “searching for records”

Find and Replace dialog box

-
v
-

-~

e e b ra—

= O

1. On the “Edit” menu.

2. Click “Find”.
3. In the “Find What” box,

type the field to search.

4. Select other options for

find “Look In”, Match or
etc.

5. Click “Find Next” button.

NB; shortcut key
Ctrl+ F

Steps of “Replace a records”

On the “Edit” menu.

2. Click “Replace” (Find and

Replace dialog box is
displayed).

3. Inthe “Find What” box, type

the name of field to replace.

4. In the “Replace with” box,

type field to replace with
respectively.

5. Select other options for find

“Look In”, Match or etc.

6. Click “Replace” or “Replace
All” button.
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Steps of “copying records”

(DT Tm e e o o e

= O

f “moving records”

tps o)

lage d = m

e

-
-
-
g
-
-
E

i
l

1. Select the record(s) to

be copied.
2. On the “Edit” menu.
3. Click “Copy”.
4. Select the target
datasheet to copy.
5. On the “Edit” menu.
6. Click “Paste”.
NB: shortcut key for “Copy”
Ctrl+ C
shortcut key for “Paste”
Ctrl +V

1. Select the record(s) to
be moved.

2. Click “Cut command on
the standard toolbar.

3. Select the target
datasheet to move.

4. Click “Paste” command
on the standard toolbar.

NB; shortcut key for move.
Ctrl + X
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Steps of “Sorting records”

-

Open the table in
datasheet view.

Select the records to
be sorted.

On the “Record”
menu.

Point to “Sort”.

Click “Ascending” or
“Descending”.

records”

Open the table in
datasheet view.

Select the records to be
filtered.

On the “Record” menu.
Point to “Filter”.

Select the type of filter
you want to apply.

In the datasheet, click a
down arrow of the field
to set the filter option.
Click “Apply Filter”
button on the toolbar.
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Steps of “adjust the column size”

1.

Point to the column
border between the
field’s header.
(mouse pointer sign
will be changed to
black cross sign).

Change the column
size up to where you
require using drag
and drop.

Point to the border between
two rows in the row header.
(mouse pointer sign will be
changed to black cross
sign).

On the “Format” menu.
Click “Row height”. (Row
Height dialog box is
displayed).

Delete current row height
and type the new row height
which you want to adjust.

Click “OK” button.
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1. Select the column of
the field you wish to
move by pointing to
the desired file
name.

2. Drag the column
e right or left to the top
of the field where
you want your field
to appear and then
drop.

jiﬁiﬁiﬁiﬂ
&% S3R23EEEE D
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Modifying table structure

m Once you create a table, you may need to add
more fields, remove some fields, reorder the
fields or change fields data types and properties.
Before you modify the table it is important to
save a copy to avoid losing everything in case
you make a mistake.

m |f a table contains data and you make changes
to the field data type, MS-Access may refuse to
implement the changes. To avoid this problem,
exit without saving and delete all the records
from the table then return to the design view.
You can then import a copy or copies of tables
you backed up.
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Steps of “make a copy of your table”

A ——
= ";‘ 1. On the “File” menu.
= | 2. Click “Save As/Export.
[ - (dialog box is
displayed).

3. Choose whether to
save to another
(external) database or
the current database.

4. Type a new name for
your table.

5. Click “OK” button.

1. Open the table in
design view.

2. Select the field or
fields to be modified
and make the
necessary changes.

3. Click the “Save”
button to save the
changes.
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Importing tables

m You can import a table from another
database or a spreadsheet into your
database.

-

Steps of “import a table or a worksheet”

Import dialog box

.y

®

On the “File” menu.

Point to “Get External Data”.
Click “Import”. (Import dialog
box is displayed).

Select the database you
wish to import data from.
Click “Import” button.
(Object dialog box is
displayed as shown in figure
below).

Click “Table” tab.

Select the table(s) you wish
to import.

Click “OK” button.
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Form designs

m A form is an interface that
enables the user to view and
make data entries into an

A sample form underlying table more easily.

3 Rent entry form = e O A form is designed using
*|tenam WE graphical objects called
TenartName Ak controls.
g O A control is an object
s e such as textbox,
fie il checkbox, command
et W (TIbA ot 2 button or shapes placed

on form design grid to
display data or perform
actions. 469

-

Types of controls

m Bound — in this the source of data is a field
in a table or query.

m Unbound — this control is not connected to
any data source.

470
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Form designer

m You design or modify
a form layout by

Form designer dragging these
controls to the
required position.
Figure right shows a
form designer for a
table called exam
entry.

Creating a form layout using form wizard

m To create a form layout, you can either use the form
wizard or start from scratch. Using the form wizard you
can create either a columnar, a tabular a datasheet or
a justified form layout.

O Columnar form: the fields for each record are displayed

down a column i.e. each value displays on a separate line
with field labels to the left.

[0 Tabular: records are displayed from left to right across the
page and labels appear at the top of each column. Each row
represents a new record.

O Datasheet: the form resembles a table datasheet view.
1 Justified: one record occupies the whole form.
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Steps of “create a form using the wizard” 1

1. Click “Form” tab.

2. Click “New”. (New Form
dialog box is displayed).

3. Select “Form Wizard”.

4. Select the name of the
table or query that
includes the data you
want to add into the
form from down arrow
list.

5. Click “OK” button.

Steps of “crating a form layout using form wizard” 2.

Form Wizard dialog box (step 1)

=3 6. Select the fields to
add into the form by
clicking the “>”
button or click “>>"
to add all fields.

7. Click “Next” button.
8. Select the layout you
wish to use

“Columnar”, Tabular”
or etc.

9. Click “Next” button.

-
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Steps of “crating a form layout using form wizard” 3

Form Wizard dialog box (step 3)

[ ——— 10. Select the style you
wish to use “Blends”,
“Blueprint” or etc.

11. Click “Next” button.

12. Type the name of the
form title in the box.

13. Click “Finish” button.
(MS-Access will
automatically display
the form on the screen).

Creating a form using autoform wizard

m You can easily create a form using the
“Autoform wizard”. This wizard creates a
form for you automatically by asking you
very minimal questions. The form includes
all the fields from the selected table.
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Steps of “construct an autoform”

New Form dialog box (AutoFrom)
H—— Click “Form” tab.
1 A~ 2. Click “New”. “New Form
T | dialog box is displayed).
o SR 3. Select autoform layout
s Vowd “Columnar”, “Tabular” or etc.
g T 4. In“Choose the table or query
where the object data
comes”, select the table or

query form from down arrow
!cist you wish to create a form
or.

5. Click “OK” button.

6.  Click “Save” button on the
toolbar. (Save As dialog box
is displayed).

7. Type the name of the form.

8. Click “OK” button.

Steps of “creating a form from scratch”

New Form dialog box (Design View)

1. Click “From” tab.

2. Click “New”. (New Form dialog
box is displayed).

3. Select the “Design view” from the
list.

4. In“Choose the table or query
where the object data comes”,
select the table or query form
from down arrow list you wish to
create a form for.

5. Click “OK” button. (a form with
controls for all fields is
displayed).

6.  Arrange the form as you want.
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1. On the “View” menu.

2. Click “Field list”. (the
field of the table you
selected is
displayed).

3. Drag and drop each
field and arrange
them on the grid.

4. Click “Save”
command on the
toolbar.

Adding and displaying records

m The form provides the user
with navigation buttons
located at the bottom that

Navigation buttons can be used to navigate the

e e v e - | form as shown in figure

) . below. The functions of the
ot  Bom— buttons can be summarized
HoaseNumbwe A1 from left to right as follows:
Month Jenuary 1. Displays the first record in the

e s table.
Record (41 « [ T [» b4 Displays the previous record.
2 e

Displays the next record.
Displays the last record.
Used to add a new record.

a M LN
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Steps of “format controls on a form” (resize)

==

Using queries

Open the form in design
view.

Select the field which you
want to resize. (place
holders are displayed
around field).

Place the mouse pointer on
the place holder. (mouse
pointer sign will be changed
to a double-sided arrow
sign).

Resize using drag and
drop.

m Queries are the fastest way to search for
information in a database. It also enables
the user display specific records and also
perform calculations on field from tables.

482
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Types of queries

m Select query — most commonly used, it is
used for searching and analysing data in
one or more tables. It lets the user specify
the search criteria.

m Action query — these are used to make
changes to many records once.

483
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Types of action queries

m Update — updates data in table.

m Append query — adds data in a table from
one or more tables.

m Make table query — creates a new table
from a dynast.

m Delete query — deletes specified records
from one or more tables.

484
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Steps of “creating a select query using wizard” 1

New Query dialog box
1. Click “Queries” tab.
e 2. Click “New”. (New query
E;']\ @ dialog box is displayed).
i A 3. Click “Simple Query Wizard”.
e 4. Click “OK” button.
. 5. Select the name of the table
— or query that includes the

data you want to add into the
query from down arrow list.

6. Select the fields to add into
the query by clicking the “>”
button or click “>>” to add all
fields.

7. Click “Next” button.

Simple Query Wizard dialog box (step 1)

Steps of “creating a select query wizard 2”

Simple Query Wizard (step 2)

7. Select “Detail” or
“Summary”.

8. Click “Next” button.

’;:'g‘i 9. Type the title name of
query in the box.

10. Click “Finish” button.
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Steps of “creating a select query from in design view” 1

New Query dialog box (Design view)

e —
B —
] EEE

Dagsearnn O wt |

e Dng - W
Fond Linatad Guary Wawt

Omote v 2wy v md
» rows

@l o e

Show Table dialog box {design view)

Click “Queries” tab.

Click “New”. (New query
dialog box is displayed).
Select “Design View”.
Click “OK” button. (Show
Table dialog box is
displayed).

Select table, query or both

which you want to add into
the query from each tab.

Click “Add” button.

After you add, click “Close”
button.

Steps of “creating a select query from in design view” 2

Query By Example design grid

m The query design grid

opens. In MS-Access
it is called “Query-By-
Example” (QBE). This
lets the user to design
a query. Figure right
is QBE grid for a table
called Exam.
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Parts of the query grid

m Field row —fields from a table or tables to be used are
arranged in this row. Each field should occupy its column.

m Table row — indicates the table providing the fields.

m Sort row — by clicking the down arrow in the sort cell, you
can specify the sort order i.e. ascending, descending or not
sort.

m Show row — by clicking the Show box, you specify whether
to display the field in the query results. When the box is not
checked, the field will not be displayed.

m Criteria row — this is where you type conditional statement
that will be used by the query to display specific records.

m Or row — used to specify an alternative condition e.g. if you
want to display records with a field called City, with items
Nairobi or Embu, type Nairobi in criteria cell and Embu in
the Or cell.

g
Specifying the criteria search

m To search for a particular set of records,
the users have to enter a conditional
statement in the criteria row. For example
if you have a table called employees with
one of the fields as salary, you can display
all the employees earning more than Shs.
5,000 by typing>5000 in the criteria row,
salary column.

490
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Other examples of specifying the criteria search 1

m  To define criteria, use either relational or logical
operators. Relational operators include less than (<),
greater than (>), greater than or equal to (>=), less
than or equal to (<=), not equal to (<>) and equal to
(=). Logical operators include AND, OR and NOT.

m  Use AND to display values in a specific range. For
example, to display records from the employees table
with salaries above 4000 but less than 6000, type,
>4000 AND <6000 on the criteria row in the salary
column. All the employees who meet this condition will
be displayed.

m  Use OR if you wish to get either one of two values. For
example, if you wish to get those employees either in
Nairobi OR Embu.

"
Other examples of specifying the criteria search 2

= If you want to display data in a particular range, use the
word Between. For example, instead of typing, >4000 AND
<6000, type Between 4000 And 6000.

m |f you want to list all records except those that you do not
want to see, use NOT. For example, if you type NOT 6000
in the salary column of the employees table, all employees
records will be displayed except those with their salary as
6000.

m To display records you are not sure of the field name but at
least you can remember a few characters, use LIKE and the
wildcards. Wildcards are special symbols mostly an asterisk
and a question mark used in place of other characters. For
example, to display all names starting with “Sm” followed by
any other character, type Like Sm? Like */*/1993 lists
records created in 1993 regardless of the day or month.
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== g e 1. Open the query in
' design view.

2. From the field list of
the underlying table,
drag each field and

L"l place it in the field

3 l row.

Steps of “saving the query”

Save command on the toolbar

1. Click “Save” button
on the toolbar or
from the “File” menu.
(Save As dialog box

is displayed).
Save As dialog box (query)
St = 2. Type name of the
(e — query in the box.
E i

3. Click “OK” button.
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Steps of “running the query”

Run a query

m  Click “Run” button on the
toolbar as shown in figure
right above or “Run”
command from the “Query”
menu. (results of the query
is displayed).

NB: you can also view the
results of your query any
other time by selecting the
query, then click “Open”
button from the database

oo window.

- O
Steps of “sorting the dynaset”

1. Click the down arrow
button of the “Sort”.
(list is displayed).

2. Select “ascending”
or “descending”.
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Steps of “delete fields from the query grid”

1. Open the query in
design view.

2. Select the field column
you wish to delete.

3. On the “Edit” menu.

4. Click “Delete”.

5. After you delete, click
“Save” command on

the toolbar to save the
changes.

‘E;-' 1. Open the query in design
ggj * view.
s 2. Position the mouse pointer
e at the boundary that
= separates columns. (mouse
pointer sign will be changed

block cross sign).

3. Double click on the
boundary to autofit cell
content.

4. Click “Save” command on
the toolbar to save the
changes.
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Steps of “modify a criteria statement, select query”

‘%}?-:}E} =LA - 1. Open the query in

Er—itd - design view.

) 2. Select the field of criteria

- Lo which you want to

& s modify, then change the

o criteria statement as you
desire.

3. Click “Save” command
on the toolbar to save
changes.

4. Click “Run” command to
display the results of the
query for test whether
the changes have been
effected.

Performing calculations in a query.

m Unlike tables, queries let the user perform
mathematical calculations on numeric data.
You can perform calculations in a query by;

A) Creating basic formulae — to create a formula

that calculates the total marks in an underlying
table e.g. Exams table.

B) Using Total functions — with a query, you can
analyze all record fields using the inbuilt
functions such as Sum, Average, Minimum and
Maximum etc.
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Steps of “creating basic formulage”

Creating a calculated field

= I

Open the query in
design view.

In an empty cell, type an
expression that includes
a field name of each as
‘Amount: [Quantity] *
[Unit Price] as shown in
figure right above.

Click “Save” command
on the toolbar.

Click “Run” command
on the toolbar. (the
results of the
calculations is
displayed).

Steps of “use the total functions”

Open the query in design
view.

Click “Totals” command on the
tool bar. (Totals row is
displayed which is located
between “Table” row and
“Sort” row).

For each field to be analyzed,
click its cell in the “Total” row,
and then select any of the
functions from arrow down list
of “Total” row.

Set criteria and other options.
Click “Run” command on the
toolbar to preview the results.
Click “Save” command to save
the changes.
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Steps of “printing a query”

gw?v—-—’-v—
4~ -~ [
-l” - ; SR

1. Click “Queries” tab.

2. Open the query in
datasheet view you
want to print.

. On the “File” menu.

4. Click “Print”.
Select the printer
from arrow down list.

6. Set the other printing
options.

7. Click “OK” button.

Relationship in tables

m Entity — an entity is a thing or object of
significance, whether real or imagined,
about which information needs to be
known or held.

m Attribute — an attribute is any detail that
serves to qualify, identify, classify, quantify
or express the state of an entity.

m Candidate key — it’s any attribute or set of
attributes can be used to uniquely identify
a row in a table.

504
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Types of relationships

m One-to-one relationship — for a particular
field in one table there is only one
matching record in the related table.

m One-to-many relationship — for a particular
field in one table there are several
matching records in another table.

m Many-to-many relationship — for particular
records in one table there are several

matching records in the other table.

-

505

Steps of “defining relationship between tables” 1

Show Table dialog box (relationship)

Open the database.

On the “Tools” menu.

Click “Relationship. (Show
Table dialog box in
Relationship is displayed).
Select the table from Table
tab.

Click “Add” button.

After you add, click “Close”
button.

Click the field of first table
which you want to create
relationship.

Drag it to the second table
then drop. (Edit Relation ship
dialog box is displayed).
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Steps of “defining relationship between tables” 2

Edit Relationships dialog box

7. Make sure “Enforce
Referential Integrity” is
checked to ensure that all
records entered in the
related table exist in the
primary table.

8. Set other options if you
want.

Click “Create” button.
(Black line is displayed
between two tables).

NB; the field used to create the
relationship must be of the
same type and properties.

Open the query in design view.
Click “Show Table” command on
the toolbar. (Show Table dialog
box is displayed).

3. Select the tables you want to
base your query on.

4. Click “Add” button. (query is

displayed).
Show Table dialog box (query based) 5. ﬁ\fter you add, click “Close”
o utton.
— A 6. Click the field of first table which
o E"*’ you want to create relationship.
P —T ®)| 7. Drag it to the second table then
| it drop. (Edit Relation ship dialog
' f box is displayed).
‘ 8. Click “Run” command to run.
I 9. Click “Save” command to save.
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Creating reports

m Like in forms, a report
layout is also
Report layout designer designed by placing
- controls on to the
report designer as
shown in figure right.

- —

/
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Parts of a report

m Report header — this contains unbound controls that displays
title of the report.

m Page header — contains heading or labels data items to be
displayed in every column.
Detail — holds bound controls that display data items for the
table or query it was created from.

m Detail — holds bound controls that display data items for the
table or query it was created from.

m Page footer — holds a control that is to be displayed on every
page such as the page number and date. For example =Now()
displays the current date and time as set in the system clock.

m Report footer — used to display summary from a report such as
the grand total for numerical data in a particular field column.
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Creating a report

m Using wizard

OJust like the form wizard, report wizard takes
the user through a number of steps by
answering a few questions and MS-Access
automatically does the rest.

m In design view

OJust like with forms, you can create a report in
design view by placing control on the report
design grid.

-

Steps of “create a report layout using wizard” 1

T Db b 55 o ] e ]

1. Click “Report” tab.

2. Click “New”. (New
Report dialog box is
displayed).

3. Select “Report
Wizard”.

4. Click “OK” button.
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Steps of “create a report layout using wizard” 2

Report Wizard dialog box (step 1)
— 5. Select the name of the table

or query that includes the
data you want to add into the
report from down arrow list.

6. Select the fields to add into
the report by clicking the “>”
button or click “>>” to add all

!
]
1

fields.
Report Wizard dialog box (step 2) 7. Click “Next” button.
o —— 8.  Select the field If you want to

add grouping.
9.  Click “>” button to add.

10. Change the priority using
arrow sign button if you want.

11.  Click “Next” button.

Steps of “create a report layout using wizard” 3

Report Wizard dialog box step 3 _
e — 12. Select the field from
e ] down arrow list if you
, | — ] want to sort the records.
[ 12 13. Select “Ascending” or
IR T i “Descending”.
= 14. Click “Summary Options”
‘ button.
Summary Options dialog box 15. Click the check box if you

want to perform .
calculations on numerical
fields e.g. Sum, Average
or etc.

16. Click “OK” button.

17. Click “Next” button.

257



- O

Steps of “create a report layout using wizard” 4

Report Wizard dialog box (step 4)

Raport Wiesd dukeg tox (whep 5) Report Wizard clabog box {slep 6}

-
™
et I

-

18.

19.

20.

21.

22.
23.

24.

Select the type of layout
from the list.

Select orientation
“Portrait” or
“Landscape”.

Click “Next” button.

Select the type of style
form the list.

Click “Next” button.
Type the name of report
title in the box.

Click "Finish” button.

Steps of “creating a report in design view” 1

New Report dialog box (design view)

Click “Report” tab.

Click “New”. (New Report dialog
box is displayed).

Select “Design View”.

In “Choose the table or query
where the object data comes”,
select the table or query form
from down arrow list you wish to
create a form for..

Click “OK” button. (Report design
grid is displayed).

Drag each field from the field list
to the layout grid and drop it
where you want the data column
to appear.

After you place, click “Save”
command on the toolbar. (Save
As dialog box is displayed).
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Steps of “creating a report in design view” 2

Save As dialog box (report)

8. Type the name of
the report.

9. Click “OK” button.

10. Click “Print Preview”
button to view the
report.

Steps of “modifying a report layout”

1. Open the report in
design view.

2. Click report header or
footer you want to
modify.

3. Make the necessary
changes.

4. Click “Save” command
‘ on the toolbar to save
= the changes.
Click “Print Preview”
command on the toolbar
= to view the changes.

'
i
frpgrienife
]
(6]
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Steps of “add more controls onto the report layout”

1. Open the report in design
view.

2. Click “Field List” command on
the toolbar. (field list is
displayed).

3. Select one or more fields in
the field list.

4. Add field to design grid using
drag and drop and adjust the
field as you wish.

5. Click “Save” command on the
toolbar to save the changes.

6. Click “Print Preview”
command on the toolbar to
view the changes.

Click “Report” tab.

Open the report in
design view.

3. Select the control you
want to resize. (place
holders are displayed
around control).

4. Place the mouse pointer
on the place holder.
(mouse pointer sign will
be changed to a double-
sided arrow sign).

5. Drag the mouse pointer
to resize the control.
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Steps of “move a control”

g e T E— . ,
e 1. Click “Report” tab.
all 2. Open the reportin
I;L;:;J] " design view.
o 3. Select the control you
want to resize. (place
holders are displayed
around control).

J 4. Place the mouse pointer
. on the place holder until
e its sign is changed to a

s e 2 hand sign.

5. Drag the mouse pointer
to move the control.

Creating labels

m A label is a sticker or piece of paper put on
an item for the purpose of identification.
Examples of stickers are mailing labels,
label on the floppy disk where you write
your name etc. Using the report label
wizard, MS-Access lets you easily create
labels of different sizes.
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Steps of “create a label using the report wizard

New Report dialog box (Label wizard)

o brpent
| Tt e 2
Faert Pt
D it (hvm
ARt Tatnbe
For et wostes » o
e b vy o
e e et 3

i
3
I
@ﬂ

- O

Click the “Report” tab.

Click “New”. (New Report
dialog box is displayed).
Select “Label Wizard” from
the list.

In “Choose the table or query
where the object data
comes”, select the table or
query form from down arrow
list you wish to create a form
for.

Click “OK” button. (Report
design grid is displayed).
Select the size of label you
want to create.

Click “Next” button.

Steps of “creating a label using the report wizard” 2

10.

11.

Select font type,
size, weight and
color.

Click “Next” button.
Select mailing labels
from available field
by clicking “>”
button.

Click “Next” button.
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Steps of “creating a label using the report wizard” 3

Label Wizard dialog box (step 4)
T —— 12. Sort labels if you

!—"'. :‘...-..«-.:.'...._..~..-.. |

want by clicking “>”
button or click “>>"
button.

13. Click “Next” button.

14. Type the name of
the label in the box.

15. Click “Finish” button.

Label Wizard dialog box (step 5)

-
Modifying labels

m Just as you can modify a report or a form,
you can also modify a label by
manipulating the layout controls

263



- O

Steps of “modify a label”

AP
j —

[ Otieci|[@ Crovts reponin Design
I T Teses Sl Create sepon by wting i
&8 SR lm

= O

Click “Report” tab.

Click “Design” button. (the
label is displayed in design
view).

Edit the layout as desired
After you modify, click
“‘Save” command on the
toolbar.

Close the design grid.
Click “Print Preview”
command on the toolbar to
view.

Printing the reports and labels

m Before you print a report or a label, you
should first set the page options i.e. the
margins, paper size and orientation.
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Steps of “printing the reports and labels”

s

1. Click “Report” tab.

2. Select the report you want to
print.

3. Click “Preview” button. (Print
Preview window is
displayed).

4. On the “File” menu.

5. Click “Print” (Print dialog box
is displayed).

6. Select the printer from down
arrow list.

7. Set other options i.e. print
range and number of copies.

8. Click “OK” button.

Creating macros

m A macro is a set of one or more actions
used to automatically perform particular
operations such as opening a form or
printing and a report. Macros are used to
automate database applications.
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Steps of “creating
-x-:“_,:‘_ e 1.

- O

Steps of “creating

Save As dialog box (Macros)

10.

macros” 1

Click “Macros” tab.

Click “New” button. (Macro window
is displayed).

Add an action e.g. OpenTable into
action column from down arrow
list.

In the lower part, specify
arguments for the action in Action
Argument box.

Type optional comment for the
action if you need.

. Add more actions to the macro if

you want. Actions are executed in
the order you list them.

Click “Save” command on the
toolbar to save the macro.

macros’ 2

Type the name of
macro in the box.

Click “OK” button.

Click “Run”
command on the
toolbar to open the
macro.
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Enforcing database security

MS-Access provides the user with several data security
tools.

A)
B)

O]

D)

Password protection — requests the password for opening.

Encryption — compacts a database file and makes in
indecipherable by a utility program or a word processor
especially on a networked environment. Encrypting a database
doesn’t restrict access to objects by users.

Hiding database object — hide tables, queries, forms and reports
and macros from casual users. This method of protection is the
least secure because it is possible to unhide the objects.

User-level security — this is the most extensive security method
especially on a multi-user environment. A database
administrator can grant specific users or groups specific
permissions and privileges to tables, queries, forms. Reports
and macros.

-

Steps of “setup a password in MS-Access” 1

1. Open MS-Access.

2. On the “File” menu.

3. Click “Open” (Open dialog
box is displayed).

4. Click arrow down sign of
“Open” button. (open menu
is displayed).

5. Open the database in
exclusive mode which you
want to set a password.
(Security Warning dialog box
is displayed).

6. Click “Open” button.
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Steps of “setup a password in MS-Access” 2

Set Database Password dialog box 10.

On the “Tool” menu.
Point to “Security”.
Click “Set Database
Password”. (Set a
Password dialog box is
displayed).

Type the unique
password in the box.

. Re-type the unique

password in the “Verify”
box.

. Click “OK” button.

Steps of “encrypt a database” 1

Start MS-Access without opening
= . 1.

Start MS-Access without
opening a database
because you can’t
encrypt or decrypt a
database when it is
open.

On the “Tools” menu.
Point to “Security”.

Click “Encode/Decode
Database”
(Encode/Decode
Database dialog box is
displayed).
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Steps of “Encrypt a database” 2

Encode/Decode Database dialog box

5. Select the database you
want to encode or
decode.

6. Click “OK” button.
(Encode Database
dialog box is displayed).

7. Select the location from
down arrow list to save.

8. Type the file name in
the “Name box.

9. Click “OK” button.

1. On the “View” menu.

2. Click “Properties”.
(Properties dialog
box is displayed).

3. Checkin the
“Hidden” box.

4. Click “Apply” button.

5. Click “OK” button.
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Steps of “assign user rights and privileges” 1

. Open the database.

. On the “Tools” menu.

. Point to “Security”.

. Click “User-Level
Security Wizard”.
(Security Wizard
dialog box is
displayed).

. Click “Next” button.

Steps of “assign user rights and privileges” 2

Security Wizard dialog box (step 2)

i::-* 6. Click “Browse” button.
IFe] (Select a workgroup file
.E dialog box is displayed).
S 7. Select the location from
P shortcut keys.
= = @=1~ _
8. Type the name of file in

Select a workgroup file dialog box the box.

;i_—-,m Brwnas -‘ 9. Click “Select” button.
f 10. Type the unique “WID”
A (workgroup ID) in the
2l e @ box.

A o Co— | ]
== = 11. Click “Next” button.
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Steps of “assign user rights and privileges” 2

Security Wizard dialog box (step 3)
[ e —— 2

| 7 B Mo (0 o S e B e (B

L EE

S
=

(e

Security Wizard dialog box (step 4)

- f T ————

12.

14.

15.

16.

Check in the boxes
which you want to select
the database to help
source from each tab.

Click “Next” button.

Check in the box which
you want to include in
your workgroup
information file.

Type “Group ID” in the
box each groups.

Click “Next” button.

Steps of “assign user rights and privileges” 3

Security Wizard dialog box (step 5)

R

Security Wizard dialog box (step 6)

e T =

17.

18.
19.

20.

Select “Yes” or “No” to
grant the users group
some permission. If you
select “Yes”, you can
set some option from
each tab.

Click “Next” button”.

You can add users to
your workgroup
information file. If you
want to add, type “User
name’, “Password” and
‘PID” (personal ID) in
the each box.

Click “Next” button.
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Steps of “assign user rights and privileges” 3

Security Wizard dialog box (step 7)

e | 21.

24.

Beczmty Waswd dobg bax (ehp 8)  CIOD & UID0GE (Wsd Bakig Do

oo T - 25.

% ==

27.

22.
23.

Select “Select a user and

assign the user to groups” or

“Select a group and assign
users to the group”.

Click “Next” button.

Click “Browse” button.
(Choose a database name
dialog box is displayed).
Select the location from
down arrow list to save.
Type the “File name” in the
box.

Click “Select” button.

Click “OK” button.

Setting up startup options

m To customize your database application
workplace, there is need to specify how
the database is to be loaded.
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Steps of “set the startup options”

oo

1. On the “Tools”
menu.

2. Click “Startup”.
(Startup dialog box
is displayed).

3. Set startup options
e.g. “Application
Title”, “Application
Ilcon” or etc.

4. Click “OK” button.

Review questions 1

1. What is a relational database
management system?

2. Define the following terms: table, records
and field as used in databases.

3. State six major objects used to
manipulate data in MS-Access.

4. Explain how you can start and exit MS-
Access.

5. In MS-Access, what do the following
terms refer to: query, macro, module. s«
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Answer of review questions 1

1. Arelational database is a model where information is stored in
related structures called tables or relations.

2. Table: a structure used to store related records.
Records: related field that represents a single item or entity.

Field: logical combination of characters that can be manipulated
as a unit.

3. Objects which help the user easily manipulate and manage data
in a database include:

O Tables, forms, queries, reports, macros, modules.

4. To start MS-Access, click start, point to programs then click MS-
Access. To exit, click file then exit or simply click the close button
on the title bar.

5. Query: a database feature used to analyse data in a table.
Macro: a feature used to automate database operations.

Module: a programming environment embedded in MS-Access
used to automate database operations. 547

" BN
Review questions 2

1. Differentiate between a primary key and an
index.

2. What is normalization in reference to tables?

3. Describe various data types used in MS-
Access.

4. Explain how you would set a validation rule
when designing tables.

5. What are field properties?

6. What is the difference between a field name
and a caption? 548
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Answer of review questions 2

1. Primary key — unique field used to identify each record uniquely
for easy access and manipulation.

An index — a key not necessarily unique used to arrange data in a
table.

2. Normalisation — a technique used to make a complex database
more efficient by breaking one large table into smaller related
tables.

3. Text, number, date/time, logical (yes/no), etc.
Setting validation rule:
A)  Select the field you want to set validation rule to.
B) Inthe field properties section, click the insertion pointer in the
validation rule cell.
C) Type in the validation rule e.g. BETWEN 0 AND 100.

5.  Field properties — characteristics of a field such as size, format,
etc.

6. Field name is a combination of characters that identifies a data
item whereas a caption is a full desc 549

g
Review questions 3

1. Define the following terms:
A) Form;
B) Bound and unbound control;
2. Differentiate between tabular and columnar form layout.

3. Explain how you would create a form without using a
form wizard.

4. Why would one prefer to use a form for data input rather
than entering directly into a table?

5. Explain how you would move from one record to
another in a form.

6. Draw a simple sketch of a form that can be used to

enter all subjects marks in an examination database.
550
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Answer of review questions 3

1. Form — user interface that helps the user view records and easily
make entries into a table.

Bound controls — data field in a form layout grid that is used to
display data from the underlying table query.

Unbound control — data field in a form layout grid that is not based
on any data source.

2. Columnar form — display one record at a time with the fields
arranged downwards.

Tabular form — records are displayed across the screen from right to
left.

3. Click the design view from new form dialog box to display the form
design grid.
4. To provide an interface that let the user enter and view data easily.
5. Using the navigation button.
Student to use a word processor to sketch the form layout.

551

g

M wDnN PR

Review questions 4

Explain two tools you can use to search for data in a database.

What is Referential Integrity?
Differentiate between a table and a query.

Write down the criteria you would use to display employees’
details from a payroll database who earn between 90,000 and
240,000.

Explain how you would sort data in a query.

What is the difference between an action query and a select
query?

Explain what happens when you try to enter invalid data into a

related table for which referential integrity has been reinforced.

Explain how you would create a select query that would be
used to calculate your total score and average in ten subjetts.
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Answer of review questions 4

Query and find command.

2. A feature used to eliminate chances of entering non existing data
into child table., that do not exist in the primary table.

3. Atable is a structure used to store related records while a query is a
component used to analyse data in a table.

. Between 90,000 and 240,000.
5. 1). Click the cell that you want to use to sort a query in the sort row.

2). From the drop down list, select the sort order, i.e. descending or
ascending order.

6. Select query is used to search and analyse data in a table while
action query is used to make changes to underlying query or table.

7. Access gives a warning message and denies the user from entering
the next record.

8. Insert the totals function in a query then select SUM and AVG.

553
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Revision questions

1. What is the importance of a report generated from a
database?

2. What is the difference between a report and a label?

3. Explain how you would create a report that displays
subtotals and grand totals.

4. Dr. Garaya is a pharmacist. She wants to generate
labels that she can use to stick to medicine bottles.
Explain to her how she can generate labels of different
sizes using MS-Access database.

5. Assuming you have been appointed as the sales
representative of an insurance company, explain how
you would create annual reports that would include the

company logo at the top of every page. s5a
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Answer of revision guestions

Report — used to give a summarised information for the
purpose of presentation.

A report gives a summarised information for the
purpose of presentation while a label is a sticker placed
on an item for the purpose of identification or
description.

To create a report that displays subtotals and grand
totals, click summary options button in the report wizard
or create calculated controls in the report design grid in
the grouping field footer and report footer respectively.
Macros and modules.

See creating reports. To insert logo and drop it in the

page header in the report design grid.

g
Practical activity 1

555

m Create a database

Field Name |Data Type called Employees and
ID Number | Text in it create a table
Lastname | Text called customers with
= = the right fields:
Irst name ext a. Save the Table as
Address Text CUSTOMER.
Town Text b. In the description
Compan Text column, which is
pany optional, describe what
Date Dates/Time each field is for, e.g. ID
Number is the number
Salar rren ; .
.y Currency that identifies each
Married? Yes/No employee uniquelysss
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Practical activity 2

DVD_Code Alphanumeric
Title [Text
PurchasePrice | Currency
SalePrice

Quantity | Number

Datebought

120
|Fixed

.Fixed

| Medium

8

-

Practical activity 3-1

A) In the database, create
a table called DVDs
with the right attributes:

B) Determine the following
in A above.
i. The primary key;
i. The missing data types
and properties;
ii. Field captions.
c) Enter ten records into
the table. 557

Field name Data type
m Create a table

Student number Text .
First name Text named Exams in
Last — a COLLEGE

astname eX database with the
Maths Number fields:
Physics Number
Chemistry Number
Computer Science Number
Total Number
Position Number
Reporting Date Date/Time 558
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Practical activity 3-2

m Set the Student number as the primary key.
Using a data form, enter data for five students as

follows.
Student No.|MATHS |PHY |CHEM |COMPUTER
2001 40 50 |40 90
1983 60 70 |57 30
2002 80 30 (37 70
1513 30 63 |80 70

559

g
Practical activity 3-3

m Without using the form wizard, create a form for
the exams table such that the format is
displayed as below:

Student Name .......... Student Name .......... Total ..........

Position ..........

Reporting Date ..........

Subject Average Marks

Maths .

Physics .

Chemistry

Computer . 560
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Practical activity 4-1

m You Are the database manager, Riceland
SACCO society and you are expected to create

a database called Riceland.

Design two tables in the database, employees
and bill with the following fields:

PNo (primary key)
Natienal ID
First Name
Last Name

Satary
Sex

Date Employed

"

Practical activity 4-2

m Enter the following records in the employees’ table:

PNo (foreign key)

Bill No (primary key)

Bill Date

Bill Amount

561

PNo | National | First Last Date Salary |Sex
ID Name |Name Employed

201 (12234 |Ali Mohamed | 16-3-2002 | 40000 |M

203 | 22734 |Alice Korir 16-5-2002 | 37000 |F

207 22734 |Daniel |Karimi 16-3-2003 | 60000 |M

208 | 12234 | Pateicia | Atieno 16-3-2004 | 38000 |F

562
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Practical activity 4-3

m Enter the following records in the bills table

PNo Bill No Date Employed | Salary
201 1100 9-7-2004 3,000
203 1200 16-7-2004 7,000
201 2000 24-7-2004 2,000
208 1340 16-6-2004 800

204 1430 18-7-2004 1,700

Explain why duplicate PNo is acceptable in
Bills table and not in the employees' table  ses

g
Practical activity 4-4

m Create a calculated query based on the
two tables that will calculate and display
the following:

A) The total bill for Joe in the month of January

B) The total bill for all the employees.

564
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Practical activity 5

1. Open the Riceland database and generate a report that
displays the following:
1. Employee name, the gross salary, allowances and the net pay.
2. Subtotals and grand totals for all the employees.
3. The current date and time.

2. You have been requested by the School Principal to create a
school database that includes the following:
1. Four departments (Maths, Science, Humanities and Technical subjects);
2. Members of staff in each department;
3. Subjects offered in a department.

1. From the database, generate a grouped report for all members of
staff in each department.

2. Create labels to be placed at the door of every head of department’s
office. 565

Chapter 6
desk Top Publishing (DTP)

566
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Introduction

m Desktop publishing is application software
used in producing publication work within
the computer framework of art and design.
Microsoft Publisher is gaining ground due
to its ease of use like other Microsoft
Office programs.

567

-

Samples of publication
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Examples of publications

m Cards m Newspaper

m Posters m Calendars

m Brochures m Newsletter etc.
"

Desktop publishing can be used Iin

m Designing texts and images
m Producing publications

m Creating illustrations

m Editing texts and graphics
m Composing templates

570

285



g
Purpose of desktop publisher

m Graphics design — a typesetter can create and
edit very complex text and graphical objects like
pictures to finest details.

m Page layout design — the user can be able to
design a page layout by setting consistent
picture and objects locations dividing page in a
number of columns and creating layer.

m Printing — the main purpose of desktop publisher
is to produce publications, therefore it helps the
user prepare what is referred to as an artwork in
commercial circles for printing.

571

"
Types of desktop publishing software

m Graphical based — they are specifically
developed to edit and format graphic
objects like pictures e.g. Adobe Photoshop,
Coral draw, Harvard graphic etc.

m Layout based — these types of desktop
publishers are specifically developed to
create different page layout designs for
text and pictures e.g. MS-Publisher,
Adobe PageMaker etc.

572
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MS-Publisher 2003 window

Horizontal

Printable
area

T

rule bar 573

- O

Parts of MS-Publisher window 1

1. Paste board - it's a large blank area where you
place text and graphical objects before arranging
them on the printable area.

2. Printable area — it's the area surrounded by
margins on the pasteboard.

3. Tool box —it's a set of buttons that contains various
tools used to create and manipulate publication.

4. Master page icon — it’s placed at the bottom of the
publication window and holds icons representing
each page in the publication. A master page is
used to design the general layout that needs to be
applied in all other pages of the publication.

574
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Parts of MS-Publisher window 2

5. Rulers — they help the user to manually create
ruler guides, which are nonprinting extensions
and also to measure an object size.

6. Control palette — it's a shortcut tool bar mainly
having text and paragraph formatting
commands icons.

7. Tracking and kerning — tracking refers to
changing the visual denseness or openness of
character in a line while kerning is fixing
particular pair of letters that is too close or too
far apart from each other.

575

'_
Tool of MS-Publisher 2003

1. Select Objects — select,
move and resize text blocks
and graphical objects.

2. Horizontal and Vertical Text
Box — insert text boxes.

3. Insert Table — insert tables.

4. Insert WordArt — insert
wordarts.

5. Picture Frame — create a
frame for paste a picture.

6. Line —draw straight lines
any direction. 576

Object tool bar 1
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Tool of MS-Publisher 2003

Object tool bar 2

. Arrow — draw straight arrow

lines any direction.

8. Oval — draw ovals

autoshape.

Rectangle — draw squares
and rectangles.

. Autoshape — insert other

types of autoshape.

. Design Gallery Object —

insert design gallery objects.

577

Steps of “Starting Publisher 2003”

Starting MS-Publisher 2003

. From the “Start”

menu.

. Point to “Programs/All

Programs”.

. Point to “Microsoft

Office”.

. Click “Microsoft Office

Publisher 2003”.
(Publisher window is
displayed).
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Steps of “open the new print publication from design template

Select a category of
design templates
from task pane e.g.
“Publications for
print”, “Web Site and
E-mail” or etc.

Click a template you
want to create from
the list. (Template is
displayed).

Steps of “open the new blank print publication 1

Click “New” command on
the standard toolbar. (New
blank print publication is
displayed).

On the “File” menu.

Click “Page Setup” (Page
Setup dialog box is
displayed).

Select publication type from
the list.

Select orientation “Portrait”
or “Landscape”.

Click “OK” button.
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Steps of “open the new blank print publication” 2

— e 7
.-—_.1.1.. 1‘
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v nl a
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= = = .
10.
11.

On the “Arrange” menu.

Click “Layout Guides”.
(Layout Design dialog
box is displayed).
Set each margins.

Set other properties
from each tab.

Click “OK” button.

NB; shortcut key of “New”

Ctrl + N

Steps of “set up a publication in Publisher”

NB;

On the “View” menu.

Click “Master Page”. (master
page window is displayed).
Use the “Edit Master Pages”
toolbar to design a master
page.

Click “Close Master View”
button on the toolbar to switch
view back to foreground
pages.

shortcut key of switch to
“Master page”

Ctrl+ M

291



= I

Steps of “add text using text frame tool in Publisher”

Click tool marked “A” on the
tool box.

Select an empty area on the
pasteboard or printable area
to add text frame and create
it using drag and drop.

Click inside of the text frame.
Type the text in the text
frame.

NB; text may not fit in the created

text frame. Publisher displays
A... below the text frame.

Steps of “resize the text block”

H M:cu.thniml \

-@)ﬂ

Click “Select Object”
command on the
object toolbar.

Click text block you
want to resize.
Place the pointer on
the handle.

Drag and drop to
resize.
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Steps of “move the text block”

' 1
, Mg b adnd

- O

. Click “Select Object”

command on the object
toolbar.

. Click the text block you

want to move.

. Place the pointer on the

outline of text block and
hold down the left mouse
button.

. Drag the text object to a

new position then drop.

Importing functions

m Importing text from a word processor —
other than typing you can also import text
from a word processor file.

m Inserting graphical objects — you can
import pictures and other graphical objects
into a publisher document by linking or

embedding.
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Steps of “importing text from a word processor

1. On the “File” menu.

2. Click “Import Word
Document”. (Import Word
Document dialog box is
displayed).

3. Select the location where
document is existing from
shortcut command.

4. Select the document.

5. Click “OK” button. (the text
is pasted onto the printable
area.

Steps of “inserting graphical objects”

1. On the “Insert” menu.

2. Point to “Picture”.

3. Click “From File”. (Insert
Picture dialog box is
displayed).

4. Select the drive or folder
from shortcut menu
where the file is located.

5. Select picture you want
to insert.

6. Click “Insert” button.
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Steps of “embed or link an object”

Insert Object dialog box

On the “Insert” menu.

: j Click “Object”. (Insert Object
s dialog box is displayed).

[F] i 3. Select “Create from File”.

. Click “Browse” button. (Browse

o e v it dialog box is displayed).

b et 5. Select the drive or folder from the
shortcut menu where the file is
located.

6. Select the file you want to link or
embed.

Click “OK” button.
Check into the link check box to

link. For embedding leave the box
unchecked.

9. Click “OK” button.

Steps of “delete text in publisher”

1. Click “Select Object”
command on the
object toolbar.

2. Highlight the text
you want to delete.

3. Press “Delete” or
“‘Backspace” key.
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Steps of “delete a text object”

1. Click “Select Object”
command on the object
toolbar.

Masves et sl

: 2. Click the text object you
n want to delete. (handles
are displayed around

picture).

3. Press “Delete” or
“Backspace” key.

- O
Steps of “copy a block of text”

1. Click “Select Object”
command on the object
toolbar.

Highlight the block of text.
On the “Edit” menu.

Click “Copy”.

On the “Edit” menu.

Click “Paste”.

Move the copied block of text
where you want to paste.

N oo o M w DN

NB; shortcut key of “Copy”
Ctrl+ C
shortcut key of “Paste”
Ctrl +V
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Steps of “move a block of text”

N oo o M e N

Click “Select Object”
command on the object
toolbar.

Highlight the block of text.
On the “Edit” menu.

Click “Cut”..

On the “Edit” menu.

Click “Paste”.

Move the block of text where
you want to paste.

NB; shortcut key of “Cut”

Ctrl + X
shortcut key of “Paste”
Ctrl +V

Steps of “spell check a publication”

NB;

On the “Tools” menu.
Point to “Spelling”.

Click “Spelling”. (Check
Spelling dialog box is
displayed).

Select correct spell of word
from suggestions.

Click “Change” button. If you
want to ignore suggestions,
click “Ignore” button.

After you check, close this
dialog box from “Close”
button.

shortcut key of spelling
F7
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Steps of “find and replace”

1. On the “Edit” menu.

2. Click “Replace”. (Find and
Replace task pane is
displayed).

3. Inthe “Find What” box, type
the word(s) to be searched.

4. In the “Replace With” box,

Find and Replace task pane type the word(s) to replace

I > the found word(s).

5. Click “Find Next” or
“Replace”, “Replace All”
button.

NB; shortcut key of “Replace”
Ctrl +H

Steps of “edit a publication layout”

1. On the “View” menu.

2. Click “Master Page”.
(master page window is
displayed).

3. Make the necessary
changes using master
page toolbar.

| 4. Click “Close Master
’ , View” button to close
= - master page window.
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Editing graphical objects

m Graphical objects are clip arts and
pictures. You edit object attributes such as
size, position, colour and brightness.

- O

Steps of “edit objects attributes”

1. Click “Select Object”
command on the
object toolbar.

2. Select the object you
want to edit. (picture
toolbar is displayed).

3. Adjust the required
attributes.
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Formatting a publication

m Formatting refers to applying special
effects or attributes to the layout, text and
graphical objects.

- O

Steps of “format text” in Publisher

1. Click “Select Object”
command on the
A . object toolbar.

2. Highlight the text to
be formatted.

"‘\

R l"i;l

!:‘II fis I
TP T B g e v e et v e W

3. On the formatting
tool bar, choose font
style, size and other
attributes.
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Steps of “format text to superscript”

1. Click “Select Object”
command on the object
toolbar.

2. Highlight the text to be
superscripted.

3. On the “Format” menu.

4. Click “Font” (Font dialog
box is displayed).

5. In the “Effects” section,
check in the box of
“Superscript”.

6. Click “OK” button.

—
—-—

—
—

==

Times New Roman

Steps of “format text to subscript”

1. Click “Select Object” on
the object toolbar.

2. Highlight the text to be
subscripted.

3. On the “Format” menu.

4. Click “Font” (Font dialog
box is displayed).

5. In the “Effects” section,

c:‘z@: - | check in the box of
I “Subscript”.

6. Click “OK” button.

Times New Roman
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Paragraph and page formatting

m Paragraph formatting involves aligning
text, indenting, adding column guides,
inserting headers and footers.

O Inserting column guides — by default, a page
Is made up of one column.

MHeaders and footers — headers are lines of
text, page numbers or dates that appears at
the top of every page. Footers on the other
hand, appear at the bottom of every page.

-

Steps of “create more than one columns’

1. On the “Arrange” menu,

2. Click “Layout Guides”.
(Layout Guides dialog
box is displayed).

3. Click “Grid Guides” tab.

4. In the “Column Guides”

section, enter number
of columns required.

5. Click “OK” button.
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Steps of “insert headers and footers”

Press Ctrl + M keys to
switch to master page.

On the “View” menu.

Click “Header and Footer”
(Header and Footer toolbar
is displayed).

Insert date or time from
each command on the
header and footer toolbar.

Type words if you want to
insert to the header or
footer.

After you insert, press again
“Ctrl + M” keys to close to
master page window.

Steps of “insert page numbers”

[ull el &

[¥1 3vaw pagn mrbar on frst page

(5“ o ”‘ Carecel

On the “Insert” menu.

Click “Page Numbers”
(Page Number dialog
box is displayed).
Select position to insert
page numbers from
down arrow list.

Select alignment to
insert page numbers
from down arrow list.

Click “OK” button.
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Formatting graphical objects

m Fill and stroke — filling refers to applying a solid
colour or patterns to a drawing, while stroke
refers to line style.

m Arranging objects — if an object is hidden by
another, you need to rearrange them in order of
priority.

m Cropping graphical objects — cropping refers to
hiding unwanted parts of a graphical object
particularly in a picture.

m Grouping objects — if you have several objects in

a publication, you may want to group them
together.

-

Steps of “apply background and stroke”

1. Click “Select Object”
command on the object
toolbar.

2. Select the object you want to
apply.

On the “Format” menu.
Click “AutoShape”. (Format
AutoShape dialog box is
displayed).

5. In the “Fill” section, select
colour you want to fill from
arrow down list.

6. Inthe “Line” section, select
outer line of colour, style or
etc from down arrow list.

7. Click “OK” button.
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1. Click “Select Object”
command on the object
toolbar.

2. Select the object you
want to rotate. (handles
are displayed around
object).

On the “Arrange” menu.
Point to “Rotate or Flip”.

Click one you want to
apply to rotate e.g. “Free
Rotate”, “Rotate Left

90° ” or etc.

Steps of “arrange objects (Bring to Front)”

1. Click “Select Object”
command on the object
toolbar.

2. Select the object you
want to bring to the
front.

On the “Arrange” menu.
Point to “Order”.
Click Bring to Front”.

NB: shortcut key of “Bring to
Front”

Alt + F6
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Steps of “arrange objects (Send to Back)”

1. Click “Select Object”
command on the object
toolbar.

2. Select the object you
want to bring send to
the back.

On the “Arrange” menu.
Point to “Order”.
Click “Send to Back”.

NB; shortcut key of “Send to
Back”

Alt + Shift + F6

- O

Steps of “crop an object”

1. Click “Select Object”
command on the object
toolbar.

2. Select the object you
want to crop. (Picture
toolbar is displayed).

3. Click the “Crop”
command on the picture
toolbar. (placeholder is
displayed around
picture.

4. Place the mouse pointer
on the placeholder.

5. Drag inward up to you
want to crop.
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Before and after cropping

Before cropping After cropping

1. Click “Select Object”
command on the object
toolbar.

2. Select a object to be
grouped.
3. Hold down “Ctrl” key.

4. Select other objects to be
grouped with you already
selected.

5. Release “Ctrl” key.

6. Right click on the picture
which you selected.
(shortcut menu is displayed).

7. Click “Group”.
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Steps of “wrapping text”

= O

Samples of wrapping style

Square

Click “Select Object”
command on the toolbar.

Select object placed on the
text box.

On the “Format” menu.

Click “Picture”. (Picture dialog
box is displayed).

Click “Layout” tab.

In the “Wrapping Style”
section, select one you want
to apply e.g. Square, Tight or
etc.

Set other options if you want.
Click “OK” button.

Top and Bottom

e v et ¢

b e o e 3
e vipuaep gty
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Steps of “printing a publication” 1

Print dialog box

1. On the “File” menu.
2. Click “Print” Preview”. (Print

Preview window is displayed).
Click “Print” command on the
toolbar. (Print dialog box is
displayed).

Select printer from down arrow list.

Click “Properties” button.
(Properties dialog box is
displayed).

Set print options from each tab e.g.
Page size, Orientation or etc.

Click “OK” button.

In the “Print” dialog box, click
“Advanced Print Setting”.
(Advanced Print Setting dialog box
is displayed).

Steps of “printing a publication” 2

Advanced Print Settings dialog box

<®E —1= =
Print dialog box

9.

10.
11.

12.

In the “Separate” tab, select
“Separate” from down arrow
list of “Output” to process
cyan, magenta, yellow and
black (CMYK) separately.

Click “OK” button.

In the “Print dialog box, set
other options “Print range”
and “Number of copies.

Click “OK” button.

NB; shortcut key of “Print”

Ctrl + P
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Review guestions 1

What is desktop publishing?

Why is a desktop publisher preferred in designing documents than a word
processor.

3. Give three examples of desktop publishing software available in the market
today.

4. You have been requested as the patron of journalism club to design for
them a 5 page school magazine. The magazine layout should display the
school logo at the top of every page. Explain how you would achieve this.

What are Master pages?

What is layering as used in DTP? Why is it a very useful feature in a
desktop publisher.

Differentiate between the pasteboard and printable page.
Explain the importance of each tool on MS-Publisher’s toolbox.

9.  What commands are used in place of portrait and landscape page
orientation in MS-Publisher?

10. What are the three main purposes of a desktop publishing software?
619

-

Review questions 2

1. What are non-printing guides?

Give three nonprinting guides used in MS-
Publisher.

3. Explain how you would create different
columns on the same page.

4. What does the term gutter mean in relation to
column setting?

5. Differentiate between margin guides and
column guides.

6. Explain how you would lock column guides to
avoid accidental moving from the current
position.

620
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Review questions 3

1. Explain how you would create text using
A) Texttool;
B) Text frame;

Explain how you would draw a hexagon.

What is a text frame? How would you convert a rectangular
shape into a text frame so that you can place text in it.

What is a Control Palette?

5. Explain how you would use a Control Palette to format;
A) Characters in a text;
B) Paragraphs;
6. Differentiate between the following:
A) Kerning and tracking;
B) Change case and drop cap;

C) Fill and stroke. 621

g
Review questions 4

Give three methods that are used to transform an object.
Explain how you would rotate an object.

How would you lock an object din order to preserve
your publication design?

4. Explain how you would import an object from another
file using the Place command.

5. How would you group objects so that you can
manipulate them as a unit?

6. Whatis text wrap? Give three ways you can wrap text
on an object.

7. Define the term cropping.

8. Explain how you can rotate a triangle by 30 degrees.

9. What is object grouping.

10. Explain the concept of wrapping text around objects. ©22
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Revision gquestions 1

Define the term artwork.

What is publishing? How is desktop publishing unique compared to
word processing?

3. List any four application window layout components found in a
typical desktop publisher.

4. Explain the function of each of the following tools;

A) Pointer

B) Text

C) Rectangle tool

D) Rotate

Explain the importance of master pages.

Differentiate between margins and column guides.

How can you calibrate rules to measure in millimetres?

Explain how you can draw a triangle of height 5 cm and base 6 cm.
Why do you need to lock margins or objects in a publication?

10. Explain terms font style and line stroke. 623

© © N o O’

"
Answer of revision questions 1-1

1. Itis a publication that is ready for printing.

2. The design and production of text and graphics layouts
in mass.

Printable area, paste board, rulers and menu bar.
4. A). Selects text and graphic objects.

B). Inserts and selects text in the application.

C). Drawing rectangles.

D). Moves objects around a fixed focal point

5. Helps user set general layout options that apply to all
pages in the publication.

6. Margins mark text areas on the page along the edges
while column guides divide the page into several fields,,
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Answer of revision questions 1-2

7.
8.

10.

Right click a ruler then select millimetres.

Drag ruler guides on the screen to mark a
rectangle area of 5cm x 6 cm on the screen.
Draw a rectangle in the guides. Select the
rectangle and then click element followed by
polygon setting dialog box, select 3 sides then
click OK.

To hold them in place in order to avoid losing
the format.

Font style — the size, boldface, italics of font etc.
Line stroke — thickness of a line.

625

g
Revision questions 2

Explain how you can import a graphic into a publication.
To change the page orientation to wide, click () then
( )andselect( )from the dialog box.

To fill a polygon, click () thenselect( )and( )
from the () dialog box.

Rotating means changing the () of an object.

The () tool is used to change the zoom settings of the
application window.

() means cutting off the unwanted edges of a graphic
object.

The small black objects that appear around a selected
graphic are called (

Expert tracking means () while kerning means ().
How can you change the bold face and font size of

selected text at once? 626
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Answer of revision guestions 2

1. Click File then Place command. Browse for the file. Double
click its icon. The mouse pointer changes to become a loaded
icon. Click anywhere on the pasteboard to place the graphic.

File — Document setup — Wide — Document setup.
Element — Fill and colour type — Fill and stroke dialog box.
Angular placement.

Zoom.

Cropping.

Place holders/handles.

Changing visual denseness by fixing space between a pair of
characters.

Fixing particular pairs of letters that are too close or too far
apart from each other.

9. Using available style. 627

© N OO s ®N

g
Practical activity 1

m  Complete the school magazine so that it will be
a multiple page document with the following
sections:

School History.
Administrative structure.

3. What is offered in every academic
department.

4. School performance in national
examinations for the last two years.

Games and clubs.
Jokes and entertainment. 628
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Practical activity 2

1. Draw the following basic shapes:
A) 5 cm by 7 cm rectangle;
B) A circle with 6 cm radius;
c) A hexagon.

2. Draw a circular text frame and fill it with the following text:

1. “Computer Studies is relatively a new area of study, which is very
dynamic. Due to this reason, every one of us is expected to keep
abreast with changing trends in Information Communication and
Technology (ICT)’.

3. Format the character in bold into superscript or subscript:
A) H20
B) CM2
c) NH40H
D) 1x103
E) Fe30

629

g
Practical activity 3

1. Draw the following basic shapes:
A) An 8 cm square and rotate it to 45 degrees;

B) Draw a triangle with rounded corners and
apply fill and stroke.

Cc) A Star with 74 degrees inset and ten sides.

2. Insert a clipart from Microsoft clipart
gallery into a publication and crop it to fit
ina 2 cm* 2 cm marked area of the
screen bounded by ruler guides.

630

315



-

Practical activity 4

1. Print a copy of your school magazine
that you have developed.

2. Using a logo provided by the teacher,
measure and design it in a desktop
publishing software and then print it.

631
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